Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTasos Sahanidis <tasos@tasossah.com>2024-04-19 23:04:24 +0300
committerTasos Sahanidis <tasos@tasossah.com>2024-04-19 23:05:39 +0300
commit123ac2329f8e221695ad4300e5510f69915393df (patch)
tree4bd7fffcf197fc9553bc13b0487ace95edaaaa9e
parent7b3ef9e913069f59082b3c42754b15c9f3f6cb2c (diff)
build-support: Add gdmd-git to bootstrap ldc
-rw-r--r--build-support/gdmd-git/PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/build-support/gdmd-git/PKGBUILD b/build-support/gdmd-git/PKGBUILD
new file mode 100644
index 00000000..653ec498
--- /dev/null
+++ b/build-support/gdmd-git/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Vladimir Panteleev <arch-pkg at thecybershadow.net>
+# https://aur.archlinux.org/packages/gdmd-git
+
+pkgname=gdmd-git
+pkgver=r31.1a4bcb2
+pkgrel=1
+pkgdesc="DMD-like wrapper for GDC"
+arch=('any')
+url="https://github.com/D-Programming-GDC/gdmd"
+license=('GPL')
+provides=('gdmd')
+conflicts=('gdmd')
+depends=('perl' 'gcc-d')
+makedepends=('git')
+source=("git+https://github.com/D-Programming-GDC/GDMD.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/GDMD"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$srcdir/GDMD"
+ mkdir -p "$pkgdir"/usr/{bin,share/man/man1}
+ make install prefix=/usr DESTDIR="$pkgdir"
+}