Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml31
1 files changed, 20 insertions, 11 deletions
diff --git a/pyproject.toml b/pyproject.toml
index 207dace5..6e0fcb99 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -1,24 +1,24 @@
[build-system]
-requires = ["flit_core >=3.5.1,<4", "setuptools>=45", "wheel"]
-build-backend = "flit_core.buildapi"
+requires = ["setuptools>=67.5"]
+build-backend = "setuptools.build_meta"
[project]
name = "archinstall"
-dynamic = ["version"]
+dynamic = ["version", "entry-points"]
description = "Arch Linux installer - guided, templates etc."
authors = [
{name = "Anton Hvornum", email = "anton@hvornum.se"},
]
+license = {text = "GPL-3.0-only"}
readme = "README.md"
requires-python = ">=3.10"
keywords = ["linux", "arch", "archinstall", "installer"]
classifiers = [
- "License :: OSI Approved :: GNU General Public License v3 or later (GPLv3+)",
"Programming Language :: Python :: 3.8",
"Programming Language :: Python :: 3.9",
- "License :: OSI Approved :: GNU General Public License v3 (GPLv3)",
+ "Programming Language :: Python :: 3.10",
"Operating System :: POSIX :: Linux",
]
@@ -27,20 +27,29 @@ Home = "https://archlinux.org"
Documentation = "https://archinstall.readthedocs.io/"
Source = "https://github.com/archlinux/archinstall"
+[project.optional-dependencies]
+doc = ["sphinx"]
+
[project.scripts]
archinstall = "archinstall:run_as_a_module"
-[project.optional-dependencies]
-doc = ["sphinx"]
+[tool.setuptools]
+packages = ["archinstall", "profiles", "examples"]
+
+[tool.setuptools.package-data]
+archinstall = [
+ "examples/*.py",
+ "profiles/*.py",
+ "profiles/applications/*.py"
+]
-[tool.flit.sdist]
-include = ["docs/", "profiles", "examples", "archinstall/profiles", "archinstall/examples"]
-exclude = ["docs/*.html", "docs/_static", "docs/*.png", "docs/*.psd"]
+[tool.setuptools.dynamic]
+version = {attr = "archinstall.__version__"}
[tool.mypy]
python_version = "3.10"
exclude = "tests"
[tool.bandit]
-targets = ["ourkvm"]
+targets = ["archinstall"]
exclude = ["/tests"]