Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml32
1 files changed, 22 insertions, 10 deletions
diff --git a/pyproject.toml b/pyproject.toml
index 6e0fcb99..557418cc 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -4,7 +4,7 @@ build-backend = "setuptools.build_meta"
[project]
name = "archinstall"
-dynamic = ["version", "entry-points"]
+dynamic = ["version"]
description = "Arch Linux installer - guided, templates etc."
authors = [
{name = "Anton Hvornum", email = "anton@hvornum.se"},
@@ -12,15 +12,17 @@ authors = [
license = {text = "GPL-3.0-only"}
readme = "README.md"
requires-python = ">=3.10"
-
keywords = ["linux", "arch", "archinstall", "installer"]
-
classifiers = [
"Programming Language :: Python :: 3.8",
"Programming Language :: Python :: 3.9",
"Programming Language :: Python :: 3.10",
"Operating System :: POSIX :: Linux",
]
+dependencies = [
+ "pyparted==3.12.0",
+ "simple-term-menu==1.6.1",
+]
[project.urls]
Home = "https://archlinux.org"
@@ -28,23 +30,33 @@ Documentation = "https://archinstall.readthedocs.io/"
Source = "https://github.com/archlinux/archinstall"
[project.optional-dependencies]
+dev = [
+ "mypy==1.1.1",
+]
doc = ["sphinx"]
[project.scripts]
archinstall = "archinstall:run_as_a_module"
+[tool.setuptools.dynamic]
+version = {attr = "archinstall.__version__"}
+readme = {file = ["README.rst", "USAGE.rst"]}
+
[tool.setuptools]
-packages = ["archinstall", "profiles", "examples"]
+packages = ["archinstall"]
[tool.setuptools.package-data]
-archinstall = [
- "examples/*.py",
- "profiles/*.py",
- "profiles/applications/*.py"
+# We could specify locales/lancuages.json etc instead, but catchall works too.
+"archinstall" = [
+ "**/*.py",
+ "**/*.mo",
+ "**/*.po",
+ "**/*.pot",
+ "**/*.json",
]
-[tool.setuptools.dynamic]
-version = {attr = "archinstall.__version__"}
+# [tool.setuptools.packages.find]
+# where = ["archinstall"]
[tool.mypy]
python_version = "3.10"