index : archinstall32 | |
Archlinux32 installer | gitolite user |
summaryrefslogtreecommitdiff |
author | Anton Hvornum <anton@hvornum.se> | 2021-04-20 12:57:14 +0000 |
---|---|---|
committer | GitHub <noreply@github.com> | 2021-04-20 12:57:14 +0000 |
commit | f5ef751d53d8bb2c7d180166c196349c86057138 (patch) | |
tree | a72efaad83cecc010fa81447d28ecd7247bc6b39 /setup.py | |
parent | e32dbfbd108e9b8598e148a0873d20384c573034 (diff) | |
parent | 2b7face25222c580ebf733942d13a83469f766e5 (diff) |
-rw-r--r-- | setup.py | 29 |
@@ -1,27 +1,2 @@ -import setuptools, glob, shutil - -with open("README.md", "r") as fh: - long_description = fh.read() - -with open('VERSION', 'r') as fh: - VERSION = fh.read() - -setuptools.setup( - name="archinstall", - version=VERSION, - author="Anton Hvornum", - author_email="anton@hvornum.se", - description="Arch Linux installer - guided, templates etc.", - long_description=long_description, - long_description_content_type="text/markdown", - url="https://github.com/Torxed/archinstall", - packages=setuptools.find_packages(), - classifiers=[ - "Programming Language :: Python :: 3.8", - "License :: OSI Approved :: GNU General Public License v3 (GPLv3)", - "Operating System :: POSIX :: Linux", - ], - python_requires='>=3.8', - setup_requires=['wheel'], - package_data={'archinstall': glob.glob('examples/*.py') + glob.glob('profiles/*.py') + glob.glob('profiles/applications/*.py')}, -) +import setuptools +setuptools.setup() |