Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorAnton Hvornum <anton.feeds+github@gmail.com>2020-08-20 12:25:21 +0000
committerAnton Hvornum <anton.feeds+github@gmail.com>2020-08-20 12:25:21 +0000
commita2e676261a91302cb32d86c85cb514c0276affc2 (patch)
tree0bf6056d9298bcb0a2378c59d025e305c62dd1e8 /setup.py
parentba9d5c746f7e94b59befdcf469558e3532f4e590 (diff)
Added missing function reboot(). Also tweaked the build scripts so that they fetch a common version from the file VERSION. And some spelling tweaks for the log output.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py5
1 files changed, 4 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 6512bd8c..815376b0 100644
--- a/setup.py
+++ b/setup.py
@@ -3,9 +3,12 @@ import setuptools, glob, shutil
with open("README.md", "r") as fh:
long_description = fh.read()
+with open('VERSION', 'r') as fh:
+ VERSION = fh.read()
+
setuptools.setup(
name="archinstall",
- version="v2.0.4rc4",
+ version=VERSION,
author="Anton Hvornum",
author_email="anton@hvornum.se",
description="Arch Linux installer - guided, templates etc.",