Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorLord Anton Hvornum <anton.feeds@gmail.com>2020-11-08 14:11:24 +0100
committerLord Anton Hvornum <anton.feeds@gmail.com>2020-11-08 14:11:24 +0100
commit667e06c63e1e5207975b50b1eb4a83b84caf3d56 (patch)
tree9828fe835359c9dacf01426ce0d3d508fc1d14cd /setup.py
parentf5230fcb30998d4d61e860f9d6cabebd164561f3 (diff)
Fixed an issue where python's setuptools didn't like running bdist_wheel. Causing issues upstream on pypi because examples/ and VERSION would be missing for instance.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py37
1 files changed, 19 insertions, 18 deletions
diff --git a/setup.py b/setup.py
index 7e825129..b0a08afd 100644
--- a/setup.py
+++ b/setup.py
@@ -1,26 +1,27 @@
import setuptools, glob, shutil
with open("README.md", "r") as fh:
- long_description = fh.read()
+ long_description = fh.read()
with open('VERSION', 'r') as fh:
- VERSION = fh.read()
+ VERSION = fh.read()
setuptools.setup(
- name="archinstall",
- version=VERSION,
- author="Anton Hvornum",
- author_email="anton@hvornum.se",
- description="Arch Linux installer - guided, templates etc.",
- long_description=long_description,
- long_description_content_type="text/markdown",
- url="https://github.com/Torxed/archinstall",
- packages=setuptools.find_packages(),
- classifiers=[
- "Programming Language :: Python :: 3.8",
- "License :: OSI Approved :: GNU General Public License v3 (GPLv3)",
- "Operating System :: POSIX :: Linux",
- ],
- python_requires='>=3.8',
- package_data={'archinstall': glob.glob('examples/*.py') + glob.glob('profiles/*.py'), 'VERSION' : 'VERSION'},
+ name="archinstall",
+ version=VERSION,
+ author="Anton Hvornum",
+ author_email="anton@hvornum.se",
+ description="Arch Linux installer - guided, templates etc.",
+ long_description=long_description,
+ long_description_content_type="text/markdown",
+ url="https://github.com/Torxed/archinstall",
+ packages=setuptools.find_packages(),
+ classifiers=[
+ "Programming Language :: Python :: 3.8",
+ "License :: OSI Approved :: GNU General Public License v3 (GPLv3)",
+ "Operating System :: POSIX :: Linux",
+ ],
+ python_requires='>=3.8',
+ setup_requires=['wheel'],
+ package_data={'archinstall': glob.glob('examples/*.py') + glob.glob('profiles/*.py')},
)