Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorPyfisch <pyfisch@posteo.org>2021-04-05 15:30:18 +0200
committerDylan Taylor <dylan@dylanmtaylor.com>2021-04-08 09:20:39 -0400
commit5bc9ab3aacf86355801d44f3e99f478454dd1aa9 (patch)
tree7e0d277a3b2529ed0989aa22d984a387dbed6b3f /setup.py
parent5a07bfbebd7d16898a2426627d609bd604c03063 (diff)
Switch to setup.cfg
Configure setup.cfg to find all Python packages. Add more metadata to package.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py29
1 files changed, 2 insertions, 27 deletions
diff --git a/setup.py b/setup.py
index 35d51025..a4f49f92 100644
--- a/setup.py
+++ b/setup.py
@@ -1,27 +1,2 @@
-import setuptools, glob, shutil
-
-with open("README.md", "r") as fh:
- long_description = fh.read()
-
-with open('VERSION', 'r') as fh:
- VERSION = fh.read()
-
-setuptools.setup(
- name="archinstall",
- version=VERSION,
- author="Anton Hvornum",
- author_email="anton@hvornum.se",
- description="Arch Linux installer - guided, templates etc.",
- long_description=long_description,
- long_description_content_type="text/markdown",
- url="https://github.com/archlinux/archinstall",
- packages=setuptools.find_packages(),
- classifiers=[
- "Programming Language :: Python :: 3.8",
- "License :: OSI Approved :: GNU General Public License v3 (GPLv3)",
- "Operating System :: POSIX :: Linux",
- ],
- python_requires='>=3.8',
- setup_requires=['wheel'],
- package_data={'archinstall': glob.glob('examples/*.py') + glob.glob('profiles/*.py') + glob.glob('profiles/applications/*.py')},
-)
+import setuptools
+setuptools.setup()