Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
authorAlan Barzilay <alan-barzilay@users.noreply.github.com>2023-11-23 22:28:12 +0000
committerGitHub <noreply@github.com>2023-11-23 23:28:12 +0100
commitf6446323fcc2c972f7b38fdf484771eb4510a2f5 (patch)
treeaedf0f89da7c8dfad21e3dabb24e0134f69231ef /pyproject.toml
parent64c91cdbcba4b1dc5270c4cf4314943e5b151641 (diff)
pyproject.toml: add missing dependencies (#2257)
we were missing 2 dependencies, pyparted and systemd-python(optional), that would lead pip installations to fail sometimes. I added them and attributed systemd_python to a new optional dependency group called log since it only seems to be used for system logging: https://github.com/archlinux/archinstall/blob/64c91cdbcba4b1dc5270c4cf4314943e5b151641/archinstall/lib/output.py#L133
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml2
1 files changed, 2 insertions, 0 deletions
diff --git a/pyproject.toml b/pyproject.toml
index 8da9b1c0..f7a544f5 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -19,6 +19,7 @@ classifiers = [
]
dependencies = [
"simple-term-menu==1.6.3",
+ "pyparted==3.13.0",
]
[project.urls]
@@ -27,6 +28,7 @@ Documentation = "https://archinstall.readthedocs.io/"
Source = "https://github.com/archlinux/archinstall"
[project.optional-dependencies]
+log = ["systemd_python==235"]
dev = [
"mypy==1.7.0",
"pre-commit==3.5.0",