Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
authorAnton Hvornum <anton@hvornum.se>2023-03-31 18:14:34 +0200
committerGitHub <noreply@github.com>2023-03-31 18:14:34 +0200
commitdc5291f781c8211b535e043fc865f72eb7b70a3f (patch)
tree437734478870b028c1ad8203d92174fbb3fd0ad8 /pyproject.toml
parent1c6b0bae73a02fb91b1670e8527ff2dfb6dc3071 (diff)
Removing legacy build files setup.py and setup.cfg (#1711)
* Removing legacy build and dist files * Bumped requirement for setuptools to deal with dynamic license inclusion * Added dynamic versioning and licensing to pyproject.toml * Clarified the license according to the LICENSE file, GPL-3.0-only
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml22
1 files changed, 18 insertions, 4 deletions
diff --git a/pyproject.toml b/pyproject.toml
index 3572148e..6e0fcb99 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -1,14 +1,15 @@
[build-system]
-requires = ["setuptools>=67"]
+requires = ["setuptools>=67.5"]
build-backend = "setuptools.build_meta"
[project]
name = "archinstall"
-dynamic = ["version", "entry-points", "license"]
+dynamic = ["version", "entry-points"]
description = "Arch Linux installer - guided, templates etc."
authors = [
{name = "Anton Hvornum", email = "anton@hvornum.se"},
]
+license = {text = "GPL-3.0-only"}
readme = "README.md"
requires-python = ">=3.10"
@@ -26,11 +27,24 @@ Home = "https://archlinux.org"
Documentation = "https://archinstall.readthedocs.io/"
Source = "https://github.com/archlinux/archinstall"
+[project.optional-dependencies]
+doc = ["sphinx"]
+
[project.scripts]
archinstall = "archinstall:run_as_a_module"
-[project.optional-dependencies]
-doc = ["sphinx"]
+[tool.setuptools]
+packages = ["archinstall", "profiles", "examples"]
+
+[tool.setuptools.package-data]
+archinstall = [
+ "examples/*.py",
+ "profiles/*.py",
+ "profiles/applications/*.py"
+]
+
+[tool.setuptools.dynamic]
+version = {attr = "archinstall.__version__"}
[tool.mypy]
python_version = "3.10"