Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
authorAnton Hvornum <anton@hvornum.se>2023-06-28 14:22:07 +0200
committerGitHub <noreply@github.com>2023-06-28 14:22:07 +0200
commit5b102b0228e8ffce81341bb2bf771a082d8263c4 (patch)
tree47d299c1505e6f817ea1a530758a301b24509361 /pyproject.toml
parent1ae1f2ff1144d502830834ba5a64262f7d195e91 (diff)
Adding python-simple-term-menu to the dependency list (#1901)
* Adding python-simple-term-menu to the dependency list * Added dependencies to all binaries we call, such as 'ps' and 'mkfs' etc * Sorted the depends list - just for peace of mind * Bumped version in prep for release of rc1, also updated README a bit * Removed older python versions from classifiers
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml8
1 files changed, 3 insertions, 5 deletions
diff --git a/pyproject.toml b/pyproject.toml
index f67f1eca..83c68e1d 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -11,12 +11,10 @@ authors = [
]
license = {text = "GPL-3.0-only"}
readme = "README.md"
-requires-python = ">=3.10"
+requires-python = ">=3.11"
keywords = ["linux", "arch", "archinstall", "installer"]
classifiers = [
- "Programming Language :: Python :: 3.8",
- "Programming Language :: Python :: 3.9",
- "Programming Language :: Python :: 3.10",
+ "Programming Language :: Python :: 3.11",
"Operating System :: POSIX :: Linux",
]
dependencies = [
@@ -60,7 +58,7 @@ packages = ["archinstall"]
# where = ["archinstall"]
[tool.mypy]
-python_version = "3.10"
+python_version = "3.11"
files = "archinstall/"
exclude = "tests"
#check_untyped_defs=true