Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
authorВладислав <awayfromgalaxy@gmail.com>2021-04-27 15:18:02 +0300
committerGitHub <noreply@github.com>2021-04-27 15:18:02 +0300
commit0c6ebc7e809cabcd2aacf3e13daf5327142f3b31 (patch)
treee4ff0e9cdd04b70f83eed822fcdec067f5b2094f /pyproject.toml
parent985b7fac3ff400de9954d441480ab795222f4b24 (diff)
parentae1c4ea7c2a1d56b23c843a2318c1400ebebb1af (diff)
Merge branch 'master' into misc-cleanup
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml31
1 files changed, 29 insertions, 2 deletions
diff --git a/pyproject.toml b/pyproject.toml
index 9787c3bd..73c7a876 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -1,3 +1,30 @@
[build-system]
-requires = ["setuptools", "wheel"]
-build-backend = "setuptools.build_meta"
+requires = ["flit_core >=2,<4"]
+build-backend = "flit_core.buildapi"
+
+[tool.flit.metadata]
+module = "archinstall"
+author = "Anton Hvornum"
+author-email = "anton@hvornum.se"
+home-page = "https://archlinux.org"
+classifiers = [ "License :: OSI Approved :: GNU General Public License v3 or later (GPLv3+)",
+"Programming Language :: Python :: 3.8",
+"Programming Language :: Python :: 3.9",
+"License :: OSI Approved :: GNU General Public License v3 (GPLv3)",
+"Operating System :: POSIX :: Linux",
+]
+description-file = "README.md"
+requires-python=">=3.8"
+[tool.flit.metadata.urls]
+Source = "https://github.com/archlinux/archinstall"
+Documentation = "https://archinstall.readthedocs.io/"
+
+[tool.flit.scripts]
+archinstall = "archinstall:run_as_a_module"
+
+[tool.flit.sdist]
+include = ["docs/","profiles"]
+exclude = ["docs/*.html", "docs/_static","docs/*.png","docs/*.psd"]
+
+[tool.flit.metadata.requires-extra]
+doc = ["sphinx"] \ No newline at end of file