Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/PKGBUILDs
diff options
context:
space:
mode:
authorAnton Hvornum <anton@hvornum.se>2021-01-28 16:43:19 +0100
committerAnton Hvornum <anton@hvornum.se>2021-01-28 16:43:19 +0100
commit4a235ced59d1b3d1a1122bc85d1457477d5a239a (patch)
treee092be0ee12fc65e217a0f3fb529996b1caf7706 /PKGBUILDs
parente64bc3ae87769b192a0bb917802cfe5e7594ebd4 (diff)
Added man build steps to PKGBUILD for python-archinstall.
Diffstat (limited to 'PKGBUILDs')
-rw-r--r--PKGBUILDs/python-archinstall/PKGBUILD6
1 files changed, 6 insertions, 0 deletions
diff --git a/PKGBUILDs/python-archinstall/PKGBUILD b/PKGBUILDs/python-archinstall/PKGBUILD
index f27fb06f..2812c5c1 100644
--- a/PKGBUILDs/python-archinstall/PKGBUILD
+++ b/PKGBUILDs/python-archinstall/PKGBUILD
@@ -19,6 +19,10 @@ build() {
cd "archinstall-${pkgver}"
python setup.py build
+
+ # Build man pages
+ cd docs
+ make man
}
package() {
@@ -28,6 +32,8 @@ package() {
--prefix=/usr \
--root="${pkgdir}" \
--optimize=1
+
+ install -Dm644 docs/_build/man/archinstall.1 "${pkgdir}"/usr/share/man/man1/archinstall.1
}
# vim:ft=sh