Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/PKGBUILDs/archinstall/PKGBUILD
diff options
context:
space:
mode:
authorGiancarlo Razzolini <grazzolini@archlinux.org>2021-01-25 12:06:24 -0300
committerGiancarlo Razzolini <grazzolini@archlinux.org>2021-01-25 12:06:24 -0300
commitdb4659a3eb32efefc14a073fc9049d2cf3a551d6 (patch)
treed3ab5eefa49004ca38cacd8f7c4773c47816cef2 /PKGBUILDs/archinstall/PKGBUILD
parent5c696c4bc1f0d0e3abae105616fe783b85d6771a (diff)
Move PKGBUILD dir to PKGBUILDs dir and create a new PKGBUILD for git
Create a new PKGBUILD that builds from the current git directory for ease of testing. Moved the PKGBUILD directory to PKGBUILDs.
Diffstat (limited to 'PKGBUILDs/archinstall/PKGBUILD')
-rw-r--r--PKGBUILDs/archinstall/PKGBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/PKGBUILDs/archinstall/PKGBUILD b/PKGBUILDs/archinstall/PKGBUILD
new file mode 100644
index 00000000..d76fe7cf
--- /dev/null
+++ b/PKGBUILDs/archinstall/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Anton Hvornum <anton@hvornum.se>
+# Contributor: demostanis worlds <demostanis@protonmail.com>
+pkgname="archinstall"
+pkgver="2.1.0"
+pkgdesc="Installs launcher scripts for archinstall"
+pkgrel=1
+url="https://github.com/Torxed/archinstall"
+license=('GPLv3')
+provides=("${pkgname}")
+arch=('x86_64')
+source=("${pkgname}-v${pkgver}-x86_64.tar.gz::https://github.com/Torxed/archinstall/archive/v$pkgver.tar.gz")
+depends=('python-archinstall')
+sha256sums=('4f8221158808228833e052260590e7ecf2733de108ada134cdde6d40ab45526b')
+
+package() {
+ mkdir -p "${pkgdir}/usr/bin"
+
+ # Install a guided profile
+ cat - > "${pkgdir}/usr/bin/archinstall" <<EOF
+#!/bin/sh
+
+python -m archinstall $@
+EOF
+
+ chmod +x "${pkgdir}/usr/bin/archinstall"
+}
+
+# vim:ft=sh
+