Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/PKGBUILD
diff options
context:
space:
mode:
authorm1ten <57693631+m1ten@users.noreply.github.com>2021-06-05 13:11:57 -0400
committerGitHub <noreply@github.com>2021-06-05 13:11:57 -0400
commitf541df4e7bf94c45246f3f1e0edb6f3caeb6f7c9 (patch)
tree90de31cd688c483ba3eeb4fdb31ee0e9538166ec /PKGBUILD
parenta4033a7d3a94916f2b4972d212f9d0069fca39cd (diff)
updated makedepends and added manual
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD5
1 files changed, 4 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7a5da658..56e79112 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,16 +10,19 @@ arch=('any')
url="https://github.com/archlinux/archinstall"
license=('GPL')
depends=('python')
-makedepends=('python-setuptools')
+makedepends=('python-setuptools' 'python-sphinx')
provides=('python-archinstall')
conflicts=('archinstall' 'python-archinstall' 'python-archinstall-git')
+md5sums=('SKIP')
build() {
cd "$startdir"
python setup.py build
+ make man -C docs
}
package() {
cd "$startdir"
python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+ install -vDm 644 docs/_build/man/archinstall.1 -t "${pkgdir}/usr/share/man/man1/"
}