Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPyfisch <pyfisch@posteo.org>2021-04-05 17:58:58 +0200
committerDylan Taylor <dylan@dylanmtaylor.com>2021-04-08 09:20:39 -0400
commitd1be941336e37275a2df2dc9ff988bdf04b4f0b5 (patch)
tree303fa10272904a92d31c42aef71ab03052aa105e /PKGBUILD
parent16e6188f1decfa824ec4b886884c27cfe4914429 (diff)
Add primary PKGBUILD for testing the package
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 00000000..42946c6a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Anton Hvornum <anton@hvornum.se>
+# Contributor: Giancarlo Razzolini <grazzolini@archlinux.org>
+# Contributor: demostanis worlds <demostanis@protonmail.com>
+
+pkgname=archinstall-git
+pkgver=$(git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g')
+pkgrel=1
+pkgdesc="Just another guided/automated Arch Linux installer with a twist"
+arch=('any')
+url="https://github.com/archlinux/archinstall"
+license=('GPL')
+depends=('python')
+makedepends=('python-setuptools')
+conflicts=('archinstall' 'archinstall-python' 'python-archinstall-git')
+
+build() {
+ cd "$startdir"
+ python setup.py build
+}
+
+package() {
+ cd "$startdir"
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+}