Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPyfisch <pyfisch@posteo.org>2021-04-05 16:49:38 +0200
committerPyfisch <pyfisch@posteo.org>2021-04-05 17:11:56 +0200
commitbaaa70381b0e4478e056bcbaa2e75e5a94450a18 (patch)
tree85252ec142add8108a71378e3208751b1a291ed2 /PKGBUILD
parentecf7a2a237a04882c93fd4d743b037f7af6bc253 (diff)
Remove outdated PKGBUILD files
setup.cfg whitespace changes.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD44
1 files changed, 0 insertions, 44 deletions
diff --git a/PKGBUILD b/PKGBUILD
deleted file mode 100644
index 77e6b512..00000000
--- a/PKGBUILD
+++ /dev/null
@@ -1,44 +0,0 @@
-# Maintainer: Anton Hvornum <anton@hvornum.se>
-# Contributor: Giancarlo Razzolini <grazzolini@archlinux.org>
-# Contributor: demostanis worlds <demostanis@protonmail.com>
-
-pkgbase=archinstall-git
-pkgname=('archinstall-git' 'python-archinstall-git')
-pkgver=$(git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g')
-pkgrel=1
-pkgdesc="Just another guided/automated Arch Linux installer with a twist"
-arch=('any')
-url="https://github.com/archlinux/archinstall"
-license=('GPL')
-depends=('python')
-makedepends=('python-setuptools')
-
-build() {
- cd "$startdir"
-
- python setup.py build
-}
-
-
-package_archinstall-git() {
- depends=('python-archinstall-git')
- conflicts=('archinstall')
- cd "$startdir"
-
- mkdir -p "${pkgdir}/usr/bin"
-
- # Install a guided profile
- cat - > "${pkgdir}/usr/bin/archinstall" <<EOF
-#!/bin/sh
-python -m archinstall $@
-EOF
-
- chmod +x "${pkgdir}/usr/bin/archinstall"
-}
-
-package_python-archinstall-git() {
- conflicts=('python-archinstall')
- cd "$startdir"
-
- python setup.py install --prefix=/usr --root="${pkgdir}" --optimize=1 --skip-build
-}