Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAnton Hvornum <anton@hvornum.se>2023-02-27 23:51:22 +0100
committerGitHub <noreply@github.com>2023-02-27 23:51:22 +0100
commit2a17ba983330cf8c511b9b1fa0329acaa2631c7c (patch)
treeca347cabeaf44cedd4b6447fa006a51a6fa50e31 /PKGBUILD
parentf26b5308597273dfa182b89d265bcc59e057bd0e (diff)
Replacing flit (#1655)
* Replacing flit * Removed python-flit as a dependency * Removed note about flit * Removed flit references in pyproject.toml
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD3
1 files changed, 1 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d8e89ae2..70b18d00 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,7 +12,7 @@ arch=(any)
url="https://github.com/archlinux/archinstall"
license=(GPL3)
depends=(python)
-makedepends=(python-build python-installer python-flit python-setuptools python-sphinx python-wheel)
+makedepends=(python-build python-installer python-setuptools python-sphinx python-wheel)
provides=(python-archinstall)
conflicts=(python-archinstall)
replaces=(python-archinstall)
@@ -29,7 +29,6 @@ validpgpkeys=('256F73CEEFC6705C6BBAB20E5FBBB32941E3740A') # Anton Hvornum (Torxe
prepare() {
cd $pkgname-$pkgver
# use real directories for examples and profiles, as symlinks do not work
- # with flit or setuptools PEP517 backends
rm -fv $pkgname/{examples,profiles}
mv -v examples profiles $pkgname/
}