Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/PKGBUILD/python-archinstall
diff options
context:
space:
mode:
authorGiancarlo Razzolini <grazzolini@archlinux.org>2021-01-25 12:06:24 -0300
committerGiancarlo Razzolini <grazzolini@archlinux.org>2021-01-25 12:06:24 -0300
commitdb4659a3eb32efefc14a073fc9049d2cf3a551d6 (patch)
treed3ab5eefa49004ca38cacd8f7c4773c47816cef2 /PKGBUILD/python-archinstall
parent5c696c4bc1f0d0e3abae105616fe783b85d6771a (diff)
Move PKGBUILD dir to PKGBUILDs dir and create a new PKGBUILD for git
Create a new PKGBUILD that builds from the current git directory for ease of testing. Moved the PKGBUILD directory to PKGBUILDs.
Diffstat (limited to 'PKGBUILD/python-archinstall')
-rw-r--r--PKGBUILD/python-archinstall/PKGBUILD34
1 files changed, 0 insertions, 34 deletions
diff --git a/PKGBUILD/python-archinstall/PKGBUILD b/PKGBUILD/python-archinstall/PKGBUILD
deleted file mode 100644
index 83b174fc..00000000
--- a/PKGBUILD/python-archinstall/PKGBUILD
+++ /dev/null
@@ -1,34 +0,0 @@
-# Maintainer: Anton Hvornum <anton@hvornum.se>
-# Contributor: demostanis worlds <demostanis@protonmail.com>
-
-pkgname="python-archinstall"
-pkgver="2.1.0"
-pkgdesc="Installs ${pkgname} as a python library."
-pkgrel=1
-url="https://github.com/Torxed/archinstall"
-source=("${pkgname}-v${pkgver}-x86_64.tar.gz::https://github.com/Torxed/archinstall/archive/v$pkgver.tar.gz")
-license=('GPLv3')
-provides=("${pkgname}")
-arch=('x86_64')
-depends=('python>=3.8')
-makedepends=('python-setuptools')
-optdepends=('pyttsx3: Adds text-to-speech support for log/screen output.')
-sha256sums=('4f8221158808228833e052260590e7ecf2733de108ada134cdde6d40ab45526b')
-
-build() {
- cd "archinstall-${pkgver}"
-
- python setup.py build
-}
-
-package() {
- cd "archinstall-${pkgver}"
-
- python setup.py install \
- --prefix=/usr \
- --root="${pkgdir}" \
- --optimize=1
-}
-
-# vim:ft=sh
-