Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/doc/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'doc/Makefile.am')
-rw-r--r--doc/Makefile.am71
1 files changed, 65 insertions, 6 deletions
diff --git a/doc/Makefile.am b/doc/Makefile.am
index f748ee6b..abc761b8 100644
--- a/doc/Makefile.am
+++ b/doc/Makefile.am
@@ -1,17 +1,76 @@
-man_MANS = \
+# We have to do some funny stuff here with the manpages. In order to ensure
+# a dist tarball doesn't get put out there without manpages, we keep those
+# files listed in EXTRA_DIST no matter what. However, we only add them to
+# man_MANS if --enable-asciidoc and/or --enable-doxygen are used.
+
+ASCIIDOC_MANS = \
pacman.8 \
makepkg.8 \
+ repo-add.8 \
PKGBUILD.5 \
makepkg.conf.5 \
pacman.conf.5 \
libalpm.3
-if HAS_DOXYGEN
-man_MANS += $(wildcard man3/*.3)
+DOXYGEN_MANS = $(wildcard man3/*.3)
+
+man_MANS =
+
+if USE_ASCIIDOC
+man_MANS += $(ASCIIDOC_MANS)
endif
+if USE_DOXYGEN
+man_MANS += $(DOXYGEN_MANS)
+endif
+
+EXTRA_DIST = \
+ pacman.8.txt \
+ makepkg.8.txt \
+ repo-add.8.txt \
+ PKGBUILD.5.txt \
+ PKGBUILD-example.txt \
+ makepkg.conf.5.txt \
+ pacman.conf.5.txt \
+ libalpm.3.txt \
+ footer.txt \
+ Doxyfile \
+ $(ASCIIDOC_MANS) \
+ $(DOXYGEN_MANS)
+
+# Files that should be removed, but which Automake does not know.
+MOSTLYCLEANFILES = $(DOXYGEN_MANS) *.xml
-EXTRA_DIST = $(man_MANS)
+if USE_DOXYGEN
+all: doxygen.in
-clean-local:
- $(RM) man3/*.3
+doxygen.in:
+ $(DOXYGEN) $(srcdir)/Doxyfile
+endif
+
+if USE_ASCIIDOC
+ASCIIDOC_OPTS = \
+ -f asciidoc.conf \
+ -a pacman_version="$(PACKAGE_VERSION)" \
+ -a pacman_date="`date +%Y-%m-%d`" \
+ -a sysconfdir=$(sysconfdir)
+A2X_OPTS = \
+ -d manpage \
+ -f manpage \
+ --xsltproc-opts='-param man.endnotes.list.enabled 0' \
+ --xsltproc-opts='-param man.endnotes.are.numbered 0'
+
+$(ASCIIDOC_MANS):
+ a2x $(A2X_OPTS) --asciidoc-opts="$(ASCIIDOC_OPTS)" $@.txt
+
+# These rules are due to the includes and files of the asciidoc text
+$(ASCIIDOC_MANS): footer.txt
+pacman.8: pacman.8.txt
+makepkg.8: makepkg.8.txt
+repo-add.8: repo-add.8.txt
+PKGBUILD.5: PKGBUILD.5.txt PKGBUILD-example.txt
+makepkg.conf.5: makepkg.conf.5.txt
+pacman.conf.5: pacman.conf.5.txt
+libalpm.3: libalpm.3.txt
+endif
+# vim:set ts=2 sw=2 noet: