Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/contrib/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'contrib/Makefile.am')
-rw-r--r--contrib/Makefile.am11
1 files changed, 5 insertions, 6 deletions
diff --git a/contrib/Makefile.am b/contrib/Makefile.am
index dd0b767c..55366b47 100644
--- a/contrib/Makefile.am
+++ b/contrib/Makefile.am
@@ -1,5 +1,4 @@
OURFILES = \
- PKGBUILD.vim \
bacman \
bash_completion \
pacdiff \
@@ -7,12 +6,11 @@ OURFILES = \
pacscripts \
pacsearch \
pactree \
- vimprojects \
wget-xdelta.sh \
zsh_completion
EXTRA_DIST = \
- PKGBUILD.vim.in \
+ PKGBUILD.vim \
bacman.in \
bash_completion.in \
pacdiff.in \
@@ -20,7 +18,7 @@ EXTRA_DIST = \
pacscripts.in \
pacsearch.in \
pactree.in \
- vimprojects.in \
+ vimprojects \
wget-xdelta.sh.in \
zsh_completion.in \
README
@@ -31,12 +29,13 @@ MOSTLYCLEANFILES = $(OURFILES) *.tmp
edit = sed \
-e 's|@sysconfdir[@]|$(sysconfdir)|g' \
-e 's|@localstatedir[@]|$(localstatedir)|g' \
- -e 's|@BASH[@]|$(BASH)|g'
+ -e 's|@BASH_SHELL[@]|$(BASH_SHELL)|g'
$(OURFILES): Makefile
+ @echo ' ' GEN $@;
@rm -f $@ $@.tmp
@cp -a $@.in $@.tmp
- $(edit) $@.in >$@.tmp
+ @$(edit) $@.in >$@.tmp
@mv $@.tmp $@
all-am: $(OURFILES)