Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am14
1 files changed, 10 insertions, 4 deletions
diff --git a/Makefile.am b/Makefile.am
index 700f32aa..e07321b3 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,14 +1,20 @@
-SUBDIRS = lib/libalpm src/util src/pacman scripts doc etc pactest contrib
-
-#DISTCHECK_CONFIGURE_FLAGS = --disable-fakeroot
+SUBDIRS = lib/libalpm src/util src/pacman scripts doc etc po pactest contrib
# Some files automatically included, so they aren't specified below:
# AUTHORS, COPYING, NEWS, README
EXTRA_DIST = HACKING
+# run the pactest test suite
check-local: src/pacman
- python $(top_srcdir)/pactest/pactest.py --debug=1 \
+ $(PYTHON) $(top_srcdir)/pactest/pactest.py --debug=1 \
--test $(top_srcdir)/pactest/tests/*.py \
-p $(top_builddir)/src/pacman/pacman
rm -rf $(top_builddir)/root
+# create the pacman DB and cache directories upon install
+install-data-local:
+ for dir in "$(DESTDIR)$(localstatedir)/lib/pacman" "$(DESTDIR)$(localstatedir)/cache/pacman/pkg"; do \
+ test -z "$$dir" || $(MKDIR_P) "$$dir"; \
+ done
+
+# vim:set ts=2 sw=2 noet: