Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDan McGee <dan@archlinux.org>2009-09-29 21:08:06 -0500
committerDan McGee <dan@archlinux.org>2009-09-29 21:08:06 -0500
commit8e7652f1afd7ba5198f3aa10a94c50bb67f7a407 (patch)
treefb125716750985f491070796bd1a51211a0fe89b /configure.ac
parent2071286770b3dbe531423aa3e8517dac68f04154 (diff)
parent20392c0a025d01128eb78c6656db7c15b3fbcd89 (diff)
Merge branch 'maint'
Conflicts: lib/libalpm/dload.c
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 1e9ab35b..9f3445dd 100644
--- a/configure.ac
+++ b/configure.ac
@@ -184,11 +184,11 @@ GCC_VISIBILITY_CC
GCC_GNU89_INLINE_CC
# Host-dependant definitions
-SIZECMD="stat -c %s"
+SIZECMD="stat -L -c %s"
SEDINPLACE="sed -i"
case "${host_os}" in
*bsd*)
- SIZECMD="stat -f %z"
+ SIZECMD="stat -L -f %z"
SEDINPLACE="sed -i ''"
;;
cygwin*)
@@ -197,7 +197,7 @@ case "${host_os}" in
;;
darwin*)
host_os_darwin=yes
- SIZECMD="/usr/bin/stat -f %z"
+ SIZECMD="/usr/bin/stat -L -f %z"
SEDINPLACE="/usr/bin/sed -i ''"
;;
esac