# disable SSE2 on 486 and 686
source_i486+=('webkitgtk-2.36.3-no-sse2.arch32.patch')
source_i686+=('webkitgtk-2.36.3-no-sse2.arch32.patch')
sha256sums_i486+=('58a724b7f1092a9049186a3b8c61689c31558b6c2b587c827cec04219397adac')
sha256sums_i686+=('58a724b7f1092a9049186a3b8c61689c31558b6c2b587c827cec04219397adac')
if [ "${CARCH}" != "pentium4" ]; then
  eval "$(
    declare -f prepare | \
      sed '
        /cd.*/a patch -Rp1 -i "$srcdir"/webkitgtk-2.36.3-no-sse2.arch32.patch
      '
  )"	
fi

# do not build JIT code on non-pentium4 (breaks in micro-optimizations)
eval "$(
  declare -f build | \
    sed '
      /cmake --build build/ ! {
        /^\s*cmake / {
          h
          s/^.*$/[ "${CARCH}" != pentium4 ] || \0/
          p
          g
          s/^\s*cmake /[ "${CARCH}" = pentium4 ] || \0-DENABLE_JIT=OFF -DENABLE_C_LOOP=ON -DENABLE_SAMPLING_PROFILER=OFF /
        }
      }
    '
)"	

# linker runs out of memory on 32-bit
eval "$(
  declare -f build | \
    sed '
      3 i LDFLAGS+=" -Wl,--no-keep-memory"
      3 i CFLAGS+=" -g1"
      3 i CXXFLAGS+=" -g1"
    '
)"