eval "$(
  declare -f prepare | \
    sed '
      $ i find ${srcdir} -type f -name 'BUILD.gn' -exec sed -i "/-Wl,--fatal-warnings/d" {} \+
    '
)"

# disable ICU in webengine (why?)
eval "$(
  declare -f build | \
    sed '
      s/ -webengine-icu//
    '
)"

# let's not use too much memory, gcc tmpfiles can in this
# case also be put on a real /tmp (instead of tmpfs) to reduce
# preasure on the RAM
eval "$(
  declare -f build | \
    sed '
      /qmake/ a find . -name Makefile -exec sed -i "s@-pipe@@g" {} \\;
    '
)"

# glibc 2.33, some more tim64-affected functions for seccomp (futex_time64,
# pselect6_time64), also added missing network functions for __i386__ and missing statx
# (see also FS32#162)
source+=('qtwebengine-everywhere-src-5.15.2-glibc-2.33.patch')
sha256sums+=('4e0ea86259df3274ff917c16b1651fc5eb56521829b0eb77302c0e25b44e95b8')

eval "$(
  declare -f prepare | \
    sed '
      /patch.*qtwebengine-everywhere-src-5.15.0-sandbox-Aw-snap-for-syscalls-403-and-407/ a \
        patch -Np1 -i "${srcdir}"/qtwebengine-everywhere-src-5.15.2-glibc-2.33.patch
    '
)"