# glibc 2.28 readdir_r -> readdir hotfix (or, let's hope readdir is
# actually thread-safe internally)

source+=('hotspot-jdk8u181-b13-readdir_r.patch')
sha256sums+=('76b176e6ec65e90b1352cb42ebf6c47a11c9a632662c31ff413965d03e3a5d41')

eval "$(
  declare -f prepare | \
    sed '
       /^}$/ i cd ${srcdir}/hotspot-${_repo_ver} && patch -Np1 < "${srcdir}/hotspot-jdk8u181-b13-readdir_r.patch"
    '
)"

eval "$(
  declare -f build | \
    sed '
       s/-Wno-error=deprecated-declarations/-Wno-error=deprecated-declarations -Wno-error=deprecated/
    '
)"

# i486-specific
if [ "${CARCH}" = "i486" ]; then
  _JARCH=i386
fi