# disable LTO as it has little benefit and uses too many resources
# don't compile with clang, use gcc toolchain (clang has issues on IA32)
# disable SIMD (SSE2 for i686)
# set correct compiler and toochain tools
if [ "${CARCH}" = "pentium4" ]; then
	source+=('mozconfig-pentium4.patch')
	sha256sums+=('ca75f01d9c56fff5de04395ec91b65fb87d94bc8d10acd44472d50ca8deaeda6')
eval "$(
  declare -f prepare | \
    sed '
      $ i patch -d .. -Np1 -i "$srcdir/mozconfig-pentium4.patch"
    '
)"
fi
if [ "${CARCH}" = "i686" ]; then
	source+=('mozconfig-i686.patch')
	sha256sums+=('3de39ec7cdb2305ae635666e2909739c44d2270a8733faff90d5439c92149cdd')
eval "$(
  declare -f prepare | \
    sed '
      $ i patch -d .. -Np1 -i "$srcdir/mozconfig-i686.patch"
    '
)"
fi	

# try hard to tell ld and rust not to use too much memory (no lto, no debug info, etc.)
eval "$(
  declare -f build | \
    sed '
      2 a export RUSTFLAGS+=" -Cdebuginfo=0 -Clto=off"
      2 a export LDFLAGS+=" -Wl,--no-keep-memory -Wl,--reduce-memory-overheads"
    '
  declare -f prepare | \
    sed '
      $ i export MOZ_SOURCE_CHANGESET="DEVEDITION_${pkgver//./_}_RELEASE"
    '
)"

# do not build a first firefox, run it in headless X just to produce
# some profiling data and build it again. the penalty of using a 32-bit
# build is high enough, so optimizing based on profiling data will not
# be that helpfull IMHO.
eval "$(
  declare -f build | \
    sed '
      /.\/mach package/,/.\/mach build/d
    '
)"

# use locally cached version of firefox sources
# TODO: think about how to put this into helper functions
for ((i=0; i<${#source[@]}; i++)); do
  infos=$(
    printf '%s\n' "${source[${i}]}" | \
      sed -n '
        s@^\(\([^:]\+\)::\)\?\(git\|hg\)+\([^?#]\+\)\(?signed\)\?#\(\(tag\|commit\)=\S\+\)$@\3 \2 \4 \5 \6@
        T
        p
      '
  )
  if [ -n "${infos}" ]; then
    source[${i}]=$(
      type="${infos%% *}"
      infos="${infos#* }"
      if [ -n "${infos%% *}" ]; then
        prefix="${infos%% *}"
      else
        prefix=''
      fi
      infos="${infos#* }"
      repo="${infos%% *}"
      repo64=$(
        printf '%s' "${repo}" | \
          base64 -w0 | \
          sed 's/=/%3D/g'
      )
      infos="${infos#* }"
      if [ "${infos%% *}" = '?signed' ]; then
        key_check=$(
          printf '&valid_keys='
          printf '%s,' "${validpgpkeys[@]}" | \
            sed 's/,$//'
        )
      else
        key_check=''
      fi
      infos="${infos#* }"
      if [ -z "${prefix}" ]; then
        prefix="${repo%.git}"
        prefix="${prefix##*/}"
      fi
      prefix_64=$(
        printf '%s/' "${prefix}" | \
          base64 -w0 | \
          sed 's/=/%3D/g'
      )

      printf '%s-%s.tar.gz::https://archive-server.archlinux32.org/?t=%s&p=%s&r=%s%s&%s\n' \
        "${prefix}" \
        "${pkgver}" \
        "${type}" \
        "${prefix_64}" \
        "${repo64}" \
        "${key_check}" \
        "${infos}"
    )
  fi
done

# from VoidLinux, avoid excessive debug symbols in rust leading
# to out-of-memory situations
eval "$(
  declare -f build | \
    sed '
      5 a sed -i "s/debug_info = '\''2'\''/debug_info = '\''0'\''/" build/moz.configure/toolchain.configure
    '
)"

# don't kill build slaves by auto-guessing available CPU cores
eval "$(
  declare -f build | \
    sed '
      2 a export MOZ_MAKE_FLAGS=-j1
    '
)"

# test failure in rust code (complaining about network functions) when PGO is used,
# see https://bugzilla.mozilla.org/show_bug.cgi?id=1565757
source+=('rust-static-disable-network-test-on-static-libraries.patch')
sha256sums+=('10c5276eab2e87f400a6ec15d7ffbef3b0407ee888dea36f1128927ca55b9041')
eval "$(
  declare -f prepare | \
    sed '
      $ i patch -p1 -i "$srcdir/rust-static-disable-network-test-on-static-libraries.patch"
    '
)"

# gcc and cross PGO are not best friends, disable PGO
eval "$(
  declare -f build | \
    sed '
      /--enable-profile-generate=cross/d
      /--with-pgo-profile-path=/d
      /--with-pgo-jarlog=/d
    '
)"

# readelf: Error: Unable to seek to 0x801db328 for section headers
source+=('avoid-libxul-OOM-python-check.patch')
sha256sums+=('2f0c81a38c4578f68f5456b618fe84a78974072821488173eb55e0e72287e353')
eval "$(
  declare -f prepare | \
    sed '
      $ i patch -p1 -i "$srcdir/avoid-libxul-OOM-python-check.patch"
    '
)"

# libxul.so cannot find it's libraries
eval "$(
  declare -f package | \
    sed '
      /}/ i \
        install -dm 755 "${pkgdir}/etc/ld.so.conf.d" \
        echo "/usr/lib/${pkgname}" > "${pkgdir}"/etc/ld.so.conf.d/${pkgname}.conf \
    '
)"

# do not do profiling: it doesn't find libraries:
# "XPCOMGlueLoad error for file /build/firefox/src/firefox-70.0/obj-i686-pc-linux-gnu/dist/firefox/libxul.so:
#libmozsandbox.so: cannot open shared object file: No such file or directory
# Couldn't load XPCOM.
# ..or it will for sure run out of memory
eval "$(
  declare -f build | \
    sed '
      /msg2 "Profiling instrumented browser..."/,/.\/mach build/d
    '
)"

# libvpx has some hard-coded compiler flags for MMX, SSE, SSE2, use the correct one
# per CARCH (75.0 uses an intrisic _mm_empty now, which required the corresponding
# architecture flag to be preset - before it was merely embedding some assembly
# code with EMMS
if [ "${CARCH}" = "i686" ]; then
  CFLAGS="$CFLAGS -mmmx"
  CXXFLAGS="$CXXFLAGS -mmmx"
fi	

# actually, this should be fixed in gcc 11?
# for now let's build with gcc10
#
# https://bugzilla.mozilla.org/show_bug.cgi?id=1713071
# https://bugzilla.mozilla.org/show_bug.cgi?id=1710235
# https://gcc.gnu.org/bugzilla/show_bug.cgi?id=100644
#
#11:28.22 /usr/include/c++/11.1.0/type_traits:2933:11: error: no type named ‘type’ in
# ‘struct std::invoke_result<nsTHashtable<nsBaseHashtableET<nsUint32HashKey, RefPtr<m
#ozilla::dom::AccessibleNode> > >::PutEntry(nsTHashtable<nsBaseHashtableET<nsUint32Ha
#shKey, RefPtr<mozilla::dom::AccessibleNode> > >::KeyType, const fallible_t&)::<lambd
#a(auto:7)>, mozilla::Maybe<nsTHashtable<nsBaseHashtableET<nsUint32HashKey, RefPtr<mo
#zilla::dom::AccessibleNode> > >::EntryHandle>&&>’
#11:28.22  2933 |     using invoke_result_t = typename invoke_result<_Fn, _Args...>::
#type;
makedepends+=(gcc10)

# do not build and phone back symbols, fails anyway with:
# "panic occurred at library/alloc/src/raw_vec.rs:537: capacity overflow\n" in
# dump_syms (see also FS32#174)
eval "$(
  declare -f build | \
    sed '
      /echo.*symbol archive/,/mach buildsymbols/{s/\(.*\)/#\1/g}
    '
)"

eval "$(
  declare -f package | \
    sed '
      /export SOCORRO_SYMBOL_UPLOAD_TOKEN_FILE/,/fi/{s/\(.*\)/#\1/g}
    '
)"