# no LTO on i486
if [ "$CARCH" = 'i486' ]; then
  sed -i '
    1i options=(!lto)
  ' PKGBUILD
fi
if [ "$CARCH" == 'i486' ]; then
  eval "$(
    declare -f build | \
      sed '
        s/-ffat-lto-objects//g
      '
  )"
fi

# disable complaining about stack trace feature which leaks memory
eval "$(
  declare -f build | \
    sed '
      s/cflags="\([^"]*\)"/cflags="\1 -DBOOST_STACKTRACE_LIBCXX_RUNTIME_MAY_CAUSE_MEMORY_LEAK"/g
      s/cxxflags="\([^"]*\)"/cxxflags="\1 -DBOOST_STACKTRACE_LIBCXX_RUNTIME_MAY_CAUSE_MEMORY_LEAK"/g
    '
)"