# patch 64-bit mode compilation to 32-bit mode (and naming of
# resulting library)
# why we would not just ommit the mode and omit the naming in
# the library is beyond me..
eval "$(
  declare -f build | \
    sed '
      s/-m64/-m32/g
      s/attach_linux_amd64.so/attach_linux_i686.so/
    '
)"