source+=('LF_PINS-size.patch')
sha256sums+=('c77f581059ee6a9b248c45194d392f45f311b3b755a9de20c274e13bb1a4d28c')

eval "$(
  declare -f prepare | \
    sed '
      $ i patch -p1 -i "$srcdir/LF_PINS-size.patch"
    '
)"

# disable maintainer mode (-Werror)
eval "$(
  declare -f build | \
    sed '
      s/-Wno-dev/-Wno-dev -DMYSQL_MAINTAINER_MODE=OFF/
    '
)"

# do not build storage backends which are only available on 64-bit
eval "$(
  declare -f build | \
    sed '
      s/-DWITH_ROCKSDB=ON/-DWITH_ROCKSDB=OFF/
      s/-DTOKU_DEBUG_PARANOID=OFF/-DWITH_TOKUDB=OFF/
    '
)"

# https://bugs.mysql.com/bug.php?id=67898
# is very old and on WONTFIX, so the error message generator break
# on 32-bit with optimization, we enable debug mode with no optimizations, sorry
eval "$(
  declare -f build | \
    sed '
      s/-Wno-dev/-Wno-dev -DWITH_DEBUG=YES/
    '
)"