# enable SSE/SSE2 where appripriate
if [ "${CARCH}" = "i486" -o "${CARCH}" = "i686" ]; then
  eval "$(
    declare -f build | \
      sed '
        s|./configure |./configure --with-sse=no --with-ssse3=no --with-avx=no |
      '
  )"
fi
if [ "${CARCH}" = "pentium4" ]; then
  eval "$(
    declare -f build | \
      sed '
        s|./configure |./configure --with-sse=yes --with-ssse3=no --with-avx=no |
      '
  )"
fi

# i486 has a stack smash when building the Python bindings (see FS32#188)
if [ "${CARCH}" = "i486"  ]; then
  eval "$(
    declare -f build | \
      sed '
        /swig\/python/d
        /python setup.py build/d
      '
  )"
  eval "$(
    declare -f package_python-gdal | \
      sed '
        3 i if false; then
        $ i fi      
      '
  )"
fi