Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/extra
diff options
context:
space:
mode:
Diffstat (limited to 'extra')
-rw-r--r--extra/meson/PKGBUILD9
-rwxr-xr-xextra/meson/arch-meson22
2 files changed, 0 insertions, 31 deletions
diff --git a/extra/meson/PKGBUILD b/extra/meson/PKGBUILD
index 5e49a967..0f009bb1 100644
--- a/extra/meson/PKGBUILD
+++ b/extra/meson/PKGBUILD
@@ -16,12 +16,3 @@ checkdepends_pentium4=("${checkdepends_i686[@]}")
# still far too many tests fail, ignoring for now
unset check
unset checkdepends
-
-# fail if upstream changes arch-meson
-# we patch a version of arch-meson reading CARCH (later maybe LTOFLAGS)
-# to find out whether it should add blto to the arch flags
-for ((i=0; i<${#b2sums[@]}; i++)); do
- if [ "${b2sums[${i}]}" = '70f042a7603d1139f6cef33aec028da087cacabe278fd47375e1b2315befbfde1c0501ad1ecc63d04d31b232a04f08c735d61ce59d7244521f3d270e417fb5af' ]; then
- b2sums[${i}]='09f3035aaff3fe8ac8e57a6e718acd654c04604500abb897a4d6e3946c9e4d9db6a257b5cd3d27007bfcfd4799a2b52d8eaab38ecda16f8af69848ed3b8ac7ff'
- fi
-done
diff --git a/extra/meson/arch-meson b/extra/meson/arch-meson
deleted file mode 100755
index fac70e6a..00000000
--- a/extra/meson/arch-meson
+++ /dev/null
@@ -1,22 +0,0 @@
-#!/bin/bash -ex
-# Highly opinionated wrapper for Arch Linux packaging
-
-CARCH=$(. /etc/makepkg.conf; echo $CARCH)
-
-if [ "${CARCH}" = "i486" ]; then
- LTO="b_lto=false"
-else
- LTO="b_lto=true"
-fi
-
-exec meson setup \
- --prefix /usr \
- --libexecdir lib \
- --sbindir bin \
- --buildtype plain \
- --auto-features enabled \
- --wrap-mode nodownload \
- -D "${LTO}" \
- -D b_pie=true \
- -D python.bytecompile=1 \
- "$@"