Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/extra/firefox
diff options
context:
space:
mode:
Diffstat (limited to 'extra/firefox')
-rw-r--r--extra/firefox/PKGBUILD82
-rw-r--r--extra/firefox/firefox-111.0.1-fdlibm.patch21
-rw-r--r--extra/firefox/fix-i686-build-moz-1792159.patch18
-rw-r--r--extra/firefox/fix-i686-xsimd-incomplete.patch29
-rw-r--r--extra/firefox/mozconfig-i686.patch15
-rw-r--r--extra/firefox/mozconfig-pentium4.patch12
6 files changed, 145 insertions, 32 deletions
diff --git a/extra/firefox/PKGBUILD b/extra/firefox/PKGBUILD
index 96bfabae..172abdf7 100644
--- a/extra/firefox/PKGBUILD
+++ b/extra/firefox/PKGBUILD
@@ -4,7 +4,8 @@
# set correct compiler and toochain tools
if [ "${CARCH}" = "pentium4" ]; then
source+=('mozconfig-pentium4.patch')
- sha256sums+=('ca75f01d9c56fff5de04395ec91b65fb87d94bc8d10acd44472d50ca8deaeda6')
+ sha256sums+=('c8b5376c4ee3f7dec4c9fe2b81434df4e2f5dd7caa99c8bf4371aec3c32233af')
+ b2sums+=('6d1f48b81a430ca39e8ea8de6ffc44010c18344b0f3b1d282f7f6d6e124823f2152267c593c1d86f049a0d8a80591b20e27b3e7c2ca29f6b29b68ef4333e4828')
eval "$(
declare -f prepare | \
sed '
@@ -14,7 +15,8 @@ eval "$(
fi
if [ "${CARCH}" = "i686" ]; then
source+=('mozconfig-i686.patch')
- sha256sums+=('3de39ec7cdb2305ae635666e2909739c44d2270a8733faff90d5439c92149cdd')
+ sha256sums+=('a0e274593c8d3587c4a669e22c480997cce24789f1dff78fb0da0f1d43083d68')
+ b2sums+=('7f6a89042ab4a4c7c6727056029d0e20411fa63c6b857a0a75c95c0544e81bea565d8cb0daba0c775861d45486ca9ab5375ec564ed567bd330f72a5e1d657ea3')
eval "$(
declare -f prepare | \
sed '
@@ -28,7 +30,7 @@ eval "$(
declare -f build | \
sed '
2 a export RUSTFLAGS+=" -Cdebuginfo=0 -Clto=off"
- 2 a export LDFLAGS+=" -Wl,--no-keep-memory -Wl,--reduce-memory-overheads"
+ 2 a export LDFLAGS+=" -Wl,--no-keep-memory -Wl,--reduce-memory-overheads -Wl,--max-cache-size=16384000 "
'
declare -f prepare | \
sed '
@@ -120,7 +122,11 @@ eval "$(
eval "$(
declare -f build | \
sed '
- 2 a export MOZ_MAKE_FLAGS=-j1
+ 2 a export MOZ_MAKE_FLAGS=-j2
+ '
+ declare -f package | \
+ sed '
+ 2 a export MOZ_MAKE_FLAGS=-j2
'
)"
@@ -128,6 +134,7 @@ eval "$(
# see https://bugzilla.mozilla.org/show_bug.cgi?id=1565757
source+=('rust-static-disable-network-test-on-static-libraries.patch')
sha256sums+=('10c5276eab2e87f400a6ec15d7ffbef3b0407ee888dea36f1128927ca55b9041')
+b2sums+=('009789d3bb93ba418929019135804fc3de7de161e5be8efba7fc75646fbde395720be5b7a7d3f5d1671f459fdd2944dd14aca306bbf1c975436d4f7765d62d15')
eval "$(
declare -f prepare | \
sed '
@@ -148,6 +155,7 @@ eval "$(
# readelf: Error: Unable to seek to 0x801db328 for section headers
source+=('avoid-libxul-OOM-python-check.patch')
sha256sums+=('2f0c81a38c4578f68f5456b618fe84a78974072821488173eb55e0e72287e353')
+b2sums+=('97035e44cd1deae7bb2422c81eec7294feb51f43f460b4d7ddba083e1d8a48d265a36ca43cf1d9dee49b01ee6df0c76e0f6916cc73cb7ad9caa1c235a59da0e4')
eval "$(
declare -f prepare | \
sed '
@@ -186,23 +194,6 @@ if [ "${CARCH}" = "i686" ]; then
CXXFLAGS="$CXXFLAGS -mmmx"
fi
-# actually, this should be fixed in gcc 11?
-# for now let's build with gcc10
-#
-# https://bugzilla.mozilla.org/show_bug.cgi?id=1713071
-# https://bugzilla.mozilla.org/show_bug.cgi?id=1710235
-# https://gcc.gnu.org/bugzilla/show_bug.cgi?id=100644
-#
-#11:28.22 /usr/include/c++/11.1.0/type_traits:2933:11: error: no type named ‘type’ in
-# ‘struct std::invoke_result<nsTHashtable<nsBaseHashtableET<nsUint32HashKey, RefPtr<m
-#ozilla::dom::AccessibleNode> > >::PutEntry(nsTHashtable<nsBaseHashtableET<nsUint32Ha
-#shKey, RefPtr<mozilla::dom::AccessibleNode> > >::KeyType, const fallible_t&)::<lambd
-#a(auto:7)>, mozilla::Maybe<nsTHashtable<nsBaseHashtableET<nsUint32HashKey, RefPtr<mo
-#zilla::dom::AccessibleNode> > >::EntryHandle>&&>’
-#11:28.22 2933 | using invoke_result_t = typename invoke_result<_Fn, _Args...>::
-#type;
-makedepends+=(gcc10)
-
# do not build and phone back symbols, fails anyway with:
# "panic occurred at library/alloc/src/raw_vec.rs:537: capacity overflow\n" in
# dump_syms (see also FS32#174)
@@ -219,3 +210,52 @@ eval "$(
/export SOCORRO_SYMBOL_UPLOAD_TOKEN_FILE/,/fi/{s/\(.*\)/#\1/g}
'
)"
+
+# 214:49.30 /build/firefox/src/firefox-99.0.1/modules/fdlibm/src/math_private.h:34:21: error: conflicting
+# declaration ?typedef __double_t double_t?
+# and
+# typedef __float_t float_t;
+# /usr/include/math.h:169:21: note: previous declaration as ?typedef long double float_t?
+# typedef long double float_t;
+source+=('firefox-111.0.1-fdlibm.patch')
+sha256sums+=('ed3bb281697af7c4353a34067ffb4b18a971d40757bef2d6af3c8bf2d28d42d1')
+b2sums+=('05c7c9727201971650df4ca2e00539767fc9e159539835c641fccab5ec9577a7294e8f62f5d0670158316e5467ea121c03a36fd4ba153e1d60f3402f0430548d')
+eval "$(
+ declare -f prepare | \
+ sed '
+ $ i patch -p1 -i "$srcdir/firefox-111.0.1-fdlibm.patch"
+ '
+)"
+
+# disable stripping in mozconfig.<arch> (insists to use llvm-strip which runs
+# out of memory on libxul.so). Now 2.5 GB can be stripped to 166 MB, so we do
+# that with the normal 'strip' from binutils after 'mach install'
+eval "$(
+ declare -f package | \
+ sed '
+ /.*mach.*install/ a \
+ strip "$pkgdir/usr/lib/$pkgname/libxul.so"
+ '
+)"
+
+# from Voidlinux, enable atomics in JIT for i686
+source+=('fix-i686-build-moz-1792159.patch')
+sha256sums+=('2fb39374fd3d80eea9e346032a2a4b2bc2e357dee7380855b24bcf19b1335d06')
+b2sums+=('d20ce3eff595f85df86eaa0dfb665fc356f8987117a771f76adc4ac12046a7e82b0af182fa99f87ea1362a5026c9d0216c7b714649fef0c7294c61c8e8f4d790')
+eval "$(
+ declare -f prepare | \
+ sed '
+ $ i patch -p1 -i "$srcdir/fix-i686-build-moz-1792159.patch"
+ '
+)"
+
+# from Parabola (thanks go to bill-auger)
+source+=('fix-i686-xsimd-incomplete.patch')
+sha256sums+=('c3ce181fbb0142055aa6dd17f3cda2ba6a1e54d7a689a8c6e9cce76aa40e6544')
+b2sums+=('3e6fd4cebe0fd4c250ccf5b04e12b93e5f4cc2d139301316c987cc07a57b4b6b49b830d745520a82f5ac59da8d17f728a3ecce4dccf21804a2d6a256a6f76472')
+eval "$(
+ declare -f prepare | \
+ sed '
+ $ i patch -p1 -i "$srcdir/fix-i686-xsimd-incomplete.patch"
+ '
+)"
diff --git a/extra/firefox/firefox-111.0.1-fdlibm.patch b/extra/firefox/firefox-111.0.1-fdlibm.patch
new file mode 100644
index 00000000..f2c15a2b
--- /dev/null
+++ b/extra/firefox/firefox-111.0.1-fdlibm.patch
@@ -0,0 +1,21 @@
+diff -rauN firefox-111.0.1/modules/fdlibm/src/math_private.h firefox-111.0.1-fdlibm-patch/modules/fdlibm/src/math_private.h
+--- firefox-111.0.1/modules/fdlibm/src/math_private.h 2023-03-21 14:16:09.000000000 +0100
++++ firefox-111.0.1-fdlibm-patch/modules/fdlibm/src/math_private.h 2023-04-08 16:50:07.828564320 +0200
+@@ -30,9 +30,17 @@
+ * Adapted from https://github.com/freebsd/freebsd-src/search?q=__double_t
+ */
+
++#if defined __FLT_EVAL_METHOD__ && (__FLT_EVAL_METHOD__ == 2)
++typedef long double __double_t;
++#else
+ typedef double __double_t;
++#endif
+ typedef __double_t double_t;
++#if defined __FLT_EVAL_METHOD__ && (__FLT_EVAL_METHOD__ == 2)
++typedef long double __float_t;
++#else
+ typedef float __float_t;
++#endif
+
+ /*
+ * The original fdlibm code used statements like:
diff --git a/extra/firefox/fix-i686-build-moz-1792159.patch b/extra/firefox/fix-i686-build-moz-1792159.patch
new file mode 100644
index 00000000..592dcad9
--- /dev/null
+++ b/extra/firefox/fix-i686-build-moz-1792159.patch
@@ -0,0 +1,18 @@
+--- a/js/src/jit/shared/AtomicOperations-shared-jit.cpp
++++ b/js/src/jit/shared/AtomicOperations-shared-jit.cpp
+@@ -5,4 +5,9 @@
+ * file, You can obtain one at http://mozilla.org/MPL/2.0/. */
+
++// bug 1792159
++#if defined(__i386__) && defined(__GNUC__) && !defined(__clang__)
++# include "../../../mfbt/Attributes.h"
++#endif
++
+ #include "jit/AtomicOperations.h"
+
+--- a/config/check_spidermonkey_style.py
++++ b/config/check_spidermonkey_style.py
+@@ -68,2 +68,3 @@
+ "jit/AtomicOperationsGenerated.h", # generated in $OBJDIR
++ "../../../mfbt/Attributes.h", # unrecognized path
+ "jit/CacheIROpsGenerated.h", # generated in $OBJDIR
diff --git a/extra/firefox/fix-i686-xsimd-incomplete.patch b/extra/firefox/fix-i686-xsimd-incomplete.patch
new file mode 100644
index 00000000..c0df0054
--- /dev/null
+++ b/extra/firefox/fix-i686-xsimd-incomplete.patch
@@ -0,0 +1,29 @@
+diff --git a/dom/base/nsTextFragmentGeneric.h b/dom/base/nsTextFragmentGeneric.h
+index 10e16fcfaa..87d9e0d075 100644
+--- a/dom/base/nsTextFragmentGeneric.h
++++ b/dom/base/nsTextFragmentGeneric.h
+@@ -13,7 +13,6 @@ namespace mozilla {
+
+ template <class Arch>
+ int32_t FirstNon8Bit(const char16_t* str, const char16_t* end) {
+- const uint32_t numUnicharsPerVector = xsimd::batch<int16_t, Arch>::size;
+ using p = Non8BitParameters<sizeof(size_t)>;
+ const size_t mask = p::mask();
+ const uint32_t numUnicharsPerWord = p::numUnicharsPerWord();
+@@ -28,16 +27,6 @@ int32_t FirstNon8Bit(const char16_t* str, const char16_t* end) {
+ if (str[i] > 255) return i;
+ }
+
+- // Check one batch at a time.
+- const int32_t vectWalkEnd =
+- ((len - i) / numUnicharsPerVector) * numUnicharsPerVector;
+- const uint16_t shortMask = 0xff00;
+- xsimd::batch<int16_t, Arch> vectmask(static_cast<int16_t>(shortMask));
+- for (; i < vectWalkEnd; i += numUnicharsPerVector) {
+- const auto vect = xsimd::batch<int16_t, Arch>::load_aligned(str + i);
+- if (xsimd::any((vect & vectmask) != 0)) return i;
+- }
+-
+ // Check one word at a time.
+ const int32_t wordWalkEnd =
+ ((len - i) / numUnicharsPerWord) * numUnicharsPerWord;
diff --git a/extra/firefox/mozconfig-i686.patch b/extra/firefox/mozconfig-i686.patch
index bfe954a0..f735ccb2 100644
--- a/extra/firefox/mozconfig-i686.patch
+++ b/extra/firefox/mozconfig-i686.patch
@@ -1,7 +1,7 @@
diff -rauN a/mozconfig b/mozconfig
--- a/mozconfig 2021-03-27 17:15:18.957711830 +0100
+++ b/mozconfig 2021-03-27 17:18:01.431035465 +0100
-@@ -5,8 +5,8 @@
+@@ -5,8 +5,9 @@
ac_add_options --enable-release
ac_add_options --enable-hardening
ac_add_options --enable-optimize
@@ -9,6 +9,7 @@ diff -rauN a/mozconfig b/mozconfig
-ac_add_options --enable-linker=lld
+ac_add_options --disable-rust-simd
+ac_add_options --enable-linker=bfd
++ac_add_options --disable-webrtc
ac_add_options --disable-elf-hack
# Branding
@@ -19,8 +20,10 @@ diff -rauN a/mozconfig b/mozconfig
+
+# pentium4 specific options
+ac_add_options --disable-lto
-+export CC=gcc-10
-+export CXX=g++-10
-+export AR=gcc-ar-10
-+export NM=gcc-nm-10
-+export RANLIB=gcc-ranlib-10
++ac_add_options --disable-install-strip
++export CC=gcc
++export CXX=g++
++export AR=ar
++export NM=nm
++export RANLIB=ranlib
++export STRIP=strip
diff --git a/extra/firefox/mozconfig-pentium4.patch b/extra/firefox/mozconfig-pentium4.patch
index ff2b1602..8b51064a 100644
--- a/extra/firefox/mozconfig-pentium4.patch
+++ b/extra/firefox/mozconfig-pentium4.patch
@@ -17,8 +17,10 @@ diff -rauN a/mozconfig b/mozconfig
+
+# pentium4 specific options
+ac_add_options --disable-lto
-+export CC=gcc-10
-+export CXX=g++-10
-+export AR=gcc-ar-10
-+export NM=gcc-nm-10
-+export RANLIB=gcc-ranlib-10
++ac_add_options --disable-install-strip
++export CC=gcc
++export CXX=g++
++export AR=ar
++export NM=nm
++export RANLIB=ranlib
++export STRIP=strip