Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/extra/conky
diff options
context:
space:
mode:
Diffstat (limited to 'extra/conky')
-rw-r--r--extra/conky/PKGBUILD8
-rw-r--r--extra/conky/fix-type-mismatch.patch13
2 files changed, 21 insertions, 0 deletions
diff --git a/extra/conky/PKGBUILD b/extra/conky/PKGBUILD
new file mode 100644
index 00000000..506fad26
--- /dev/null
+++ b/extra/conky/PKGBUILD
@@ -0,0 +1,8 @@
+#see https://github.com/brndnmtthws/conky/issues/759
+sha256sums+=('842a3377b1d4fcaff8ec409b68fe6b05a9faf500f29b4d8e21cec3b4cd5b7da2')
+source+=('fix-type-mismatch.patch')
+
+prepare() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ patch -p1 -i "${srcdir}/fix-type-mismatch.patch"
+}
diff --git a/extra/conky/fix-type-mismatch.patch b/extra/conky/fix-type-mismatch.patch
new file mode 100644
index 00000000..a84d05e2
--- /dev/null
+++ b/extra/conky/fix-type-mismatch.patch
@@ -0,0 +1,13 @@
+diff --git a/src/linux.cc b/src/linux.cc
+index 0a7d4331..09fa6c99 100644
+--- a/src/linux.cc
++++ b/src/linux.cc
+@@ -1169,7 +1169,7 @@ static int open_sysfs_sensor(const char *dir, const char *dev, const char *type,
+ fd = open(path, O_RDONLY);
+ if (fd < 0) {
+ /* if it fails, strip the /device from dev and attempt again */
+- size_t len_to_trunc = std::max(7UL, strnlen(buf, 255)) - 7;
++ size_t len_to_trunc = std::max((size_t)7UL, strnlen(buf, 255)) - 7;
+ buf[len_to_trunc] = 0;
+ snprintf(path, 255, "%s%s/%s%d_input", dir, dev, type, n);
+ fd = open(path, O_RDONLY);