Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/core/systemd
diff options
context:
space:
mode:
Diffstat (limited to 'core/systemd')
-rw-r--r--core/systemd/PKGBUILD22
-rw-r--r--core/systemd/lz4-test-compress-partial.patch31
-rw-r--r--core/systemd/meson-rename-Ddebug-to-Ddebug-extra.patch26
3 files changed, 36 insertions, 43 deletions
diff --git a/core/systemd/PKGBUILD b/core/systemd/PKGBUILD
index baf567fc..be057de8 100644
--- a/core/systemd/PKGBUILD
+++ b/core/systemd/PKGBUILD
@@ -1,23 +1,11 @@
-source+=('meson-rename-Ddebug-to-Ddebug-extra.patch')
-sha512sums+=('d310e7ea099bd371eb12fb4f474f1518ddc1013612d6a53c3f5777e6a3509eb58c4b5989d31bb04784be70db5d8ca39bff47414456c3fe322194cd7b341ae70c')
+# LZ4 test fails, see upstream FS#60239
+
+source+=(lz4-test-compress-partial.patch)
+sha512sums+=('afc199c8d091c1b87fa0719b82bb29ff32595d51034127d1a8c7f83f539f52d0d8a4fa90cf22e286bf3e9104603ecfc9275c3527b9adc2d05d9bcb9234e3c208')
eval "$(
declare -f prepare | \
sed '
- /patch.*0001.*/a patch -Np1 -i ../meson-rename-Ddebug-to-Ddebug-extra.patch
+ /patch.*/a patch -Np1 -i ../lz4-test-compress-partial.patch
'
)"
-
-# i486-specific
-if [ "${CARCH}" = "i486" ]; then
- # temporary, as there is no systemd-journal user for some reason!?
- eval "$(
- declare -f package_systemd | \
- sed '
- /install.*systemd-journal/d
- '
- )"
-
- # tempoary failure, known upstream, see FS#60239
- unset check
-fi
diff --git a/core/systemd/lz4-test-compress-partial.patch b/core/systemd/lz4-test-compress-partial.patch
new file mode 100644
index 00000000..421e186f
--- /dev/null
+++ b/core/systemd/lz4-test-compress-partial.patch
@@ -0,0 +1,31 @@
+diff --git a/meson.build b/meson.build
+index 554e67e5dd..3636a0ff8c 100644
+--- a/meson.build
++++ b/meson.build
+@@ -1084,6 +1084,7 @@ conf.set10('HAVE_XZ', have)
+ want_lz4 = get_option('lz4')
+ if want_lz4 != 'false' and not fuzzer_build
+ liblz4 = dependency('liblz4',
++ version : '>= 1.8.3',
+ required : want_lz4 == 'true')
+ have = liblz4.found()
+ else
+diff --git a/src/journal/test-compress.c b/src/journal/test-compress.c
+index 7addf318d6..fb0db190b2 100644
+--- a/src/journal/test-compress.c
++++ b/src/journal/test-compress.c
+@@ -227,13 +227,10 @@ static void test_lz4_decompress_partial(void) {
+ assert_se(r >= 0);
+ log_info("Decompressed partial %i/%i → %i", 12, HUGE_SIZE, r);
+
+- /* We expect this to fail, because that's how current lz4 works. If this
+- * call succeeds, then lz4 has been fixed, and we need to change our code.
+- */
+ r = LZ4_decompress_safe_partial(buf, huge,
+ compressed,
+ 12, HUGE_SIZE-1);
+- assert_se(r < 0);
++ assert_se(r >= 0);
+ log_info("Decompressed partial %i/%i → %i", 12, HUGE_SIZE-1, r);
+ }
+ #endif
diff --git a/core/systemd/meson-rename-Ddebug-to-Ddebug-extra.patch b/core/systemd/meson-rename-Ddebug-to-Ddebug-extra.patch
deleted file mode 100644
index 12607f2a..00000000
--- a/core/systemd/meson-rename-Ddebug-to-Ddebug-extra.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-diff --git a/meson.build b/meson.build
-index 88a470a..1d864e3 100644
---- a/meson.build
-+++ b/meson.build
-@@ -765,7 +765,7 @@ substs.set('DEBUGTTY', get_option('debug-tty'))
-
- enable_debug_hashmap = false
- enable_debug_mmap_cache = false
--foreach name : get_option('debug')
-+foreach name : get_option('debug-extra')
- if name == 'hashmap'
- enable_debug_hashmap = true
- elif name == 'mmap-cache'
-diff --git a/meson_options.txt b/meson_options.txt
-index 16c1f2b..dc7951b 100644
---- a/meson_options.txt
-+++ b/meson_options.txt
-@@ -46,7 +46,7 @@ option('debug-shell', type : 'string', value : '/bin/sh',
- description : 'path to debug shell binary')
- option('debug-tty', type : 'string', value : '/dev/tty9',
- description : 'specify the tty device for debug shell')
--option('debug', type : 'array', choices : ['hashmap', 'mmap-cache'], value : [],
-+option('debug-extra', type : 'array', choices : ['hashmap', 'mmap-cache'], value : [],
- description : 'enable extra debugging')
- option('memory-accounting-default', type : 'boolean',
- description : 'enable MemoryAccounting= by default')