Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/core/pacman/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'core/pacman/PKGBUILD')
-rw-r--r--core/pacman/PKGBUILD39
1 files changed, 0 insertions, 39 deletions
diff --git a/core/pacman/PKGBUILD b/core/pacman/PKGBUILD
index 6bb4e067..562d68ec 100644
--- a/core/pacman/PKGBUILD
+++ b/core/pacman/PKGBUILD
@@ -69,42 +69,3 @@ if [ "${CARCH}" = "i486" ]; then
sha256sums[0]='SKIP'
fi
-# use muon instead of meson, no python (and meson needs python)
-makedepends=(${makedepends[@]//meson/})
-makedepends+=(muon-meson)
-
-source+=(pacman-trailing-slash-muon.patch)
-sha256sums+=(f295ff9967d38117bb5a29237716abb997197c69d8d2eeb449db49b85582be02)
-
-eval "$(
- declare -f build | \
- sed '
- /meson compile/ i \
- cd $srcdir/pacman/build
- s/meson compile.*/muon samu -v -j1/
- s/meson\(.* build\)/muon meson setup -D default_library=shared \1/
- '
- declare -f check | \
- sed '
- /meson test/ i \
- cd $srcdir/pacman/build
- s/meson.*/muon test -v/
- '
- declare -f package | \
- sed '
- /meson install/ i \
- cd $srcdir/pacman/build
- /meson install/ a \
- cd ..
- s/DESTDIR="$pkgdir" meson install -C build/muon install -d "$pkgdir"/
- '
-)"
-
-# fails happilly at the moment, going full risk now and installing it anyway..
-unset check
-unset checkdepends
-
-# overwrite wrong checksum on rust.conf? does't work in buildmaster, works
-# in chroot?! Disabling again..
-#sha256sums[5]='6fe03e6ea3f69d99d59a48847a8ae97c2160fca847c7aedf7b89d05e4aa9386d'
-