Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/core/gcc/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'core/gcc/PKGBUILD')
-rw-r--r--core/gcc/PKGBUILD39
1 files changed, 27 insertions, 12 deletions
diff --git a/core/gcc/PKGBUILD b/core/gcc/PKGBUILD
index b2d6ed81..ca003988 100644
--- a/core/gcc/PKGBUILD
+++ b/core/gcc/PKGBUILD
@@ -54,6 +54,7 @@ eval "$(
# no ADA
makedepends=(${makedepends[@]//gcc-ada/})
makedepends_i686+=('gcc-ada')
+makedepends_pentium4+=('gcc-ada')
if [ "${CARCH}" = "i486" ]; then
package_gcc-ada() {
@@ -63,7 +64,7 @@ if [ "${CARCH}" = "i486" ]; then
eval "$(
declare -f build | \
sed '
- /enable-languages/ s/,ada//
+ /enable-languages/ s/ada,//
'
)"
@@ -87,24 +88,38 @@ if [ "${CARCH}" = "i486" ]; then
'
)"
- # disable CET (Control Flow instructions endbr32/enbr64)
- eval "$(
- declare -f build | \
- sed '
- s/--enable-cet=auto/--disable-cet/
- '
- )"
+fi
-else
+makedepends=(${makedepends[@]//lib32-glibc/})
+makedepends=(${makedepends[@]//lib32-gcc-libs/})
- # force enable CET (Control Flow instructions endbr32/enbr64)
+# i486-specific: disable PGO/LTO build, uses too much resources,
+# also disabling LTO for now
+if [ "${CARCH}" = "i486" ]; then
eval "$(
declare -f build | \
sed '
- s/--enable-cet=auto/--enable-cet/
+ s/--enable-pgo-build=.*/--disable-pgo-build/
+ s/--enable-lto/--disable-lto/
+ s/--with-build-config=bootstrap-lto//
+ '
+ declare -f package_gcc | \
+ sed '
+ /make.*lto-plugin.*install/d
+ /ln.*liblto_plugin.so/d
'
)"
+fi
+# testing on 486 VMs takes too long and runs in virtual memory exhaustion
+if [ "${CARCH}" = "i486" ]; then
+ unset check
fi
-makedepends_pentium4=("${makedepends_i686[@]}")
+# disable CET on all subarchitectures (Control Flow instructions endbr32/enbr64)
+eval "$(
+ declare -f build | \
+ sed '
+ s/--enable-cet=auto/--disable-cet/
+ '
+)"