Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/core/binutils
diff options
context:
space:
mode:
Diffstat (limited to 'core/binutils')
-rw-r--r--core/binutils/PKGBUILD30
1 files changed, 7 insertions, 23 deletions
diff --git a/core/binutils/PKGBUILD b/core/binutils/PKGBUILD
index c1110778..f4694854 100644
--- a/core/binutils/PKGBUILD
+++ b/core/binutils/PKGBUILD
@@ -32,29 +32,13 @@ eval "$(
'
)"
-# i486-specific
-if [ "${CARCH}" = "i486" ]; then
- # disable CET (Control Flow instructions endbr32/enbr64)
- eval "$(
- declare -f build | \
- sed '
- s/--enable-cet/--enable-cet=no/
- '
- )"
-else
- # explicitely enable CET (Control Flow instructions endbr32/enbr64)
- # avoid "corrupt GNU_PROPERTY_TYPE (5) size: 0" warnings,
- # see:
- # https://bbs.archlinux32.org/viewtopic.php?pid=6160#p6160
- # https://bugs.archlinux32.org/index.php?do=details&task_id=82
- #
- eval "$(
- declare -f build | \
- sed '
- s/--enable-cet/--enable-cet=yes/
- '
- )"
-fi
+# disable CET on all subarchs (Control Flow instructions endbr32/enbr64)
+eval "$(
+ declare -f build | \
+ sed '
+ s/--enable-cet/--enable-cet=no/
+ '
+)"
# i486-specific: disable PGO/LTO build, uses too much resources,
# also disabling LTO for now, also disabling the gold linker