Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/community
diff options
context:
space:
mode:
Diffstat (limited to 'community')
-rw-r--r--community/aubio/PKGBUILD8
-rw-r--r--community/aubio/assert-almost.patch27
-rw-r--r--community/broadcom-wl-dkms/PKGBUILD2
-rw-r--r--community/buildah/PKGBUILD8
-rw-r--r--community/dart/PKGBUILD5
-rw-r--r--community/eclipse/PKGBUILD2
-rw-r--r--community/freebasic/PKGBUILD4
-rw-r--r--community/gap/PKGBUILD2
-rw-r--r--community/gcc7/PKGBUILD13
-rw-r--r--community/go/PKGBUILD7
-rw-r--r--community/grumpy/4f3cc3ed446170a161cf8ecb644a740ac233b005.patch30
-rw-r--r--community/grumpy/PKGBUILD18
-rw-r--r--community/grumpy/ef4791393db1ab586400d326ae7d7993e5610d00.patch26
-rw-r--r--community/mit-scheme/PKGBUILD4
-rw-r--r--community/nvidia-cg-toolkit/PKGBUILD2
-rw-r--r--community/proselint/PKGBUILD2
-rw-r--r--community/python-apache-libcloud/PKGBUILD7
-rw-r--r--community/python-iwlib/PKGBUILD2
-rw-r--r--community/python-pip-bootstrap/PKGBUILD4
-rw-r--r--community/python-redis/PKGBUILD12
-rw-r--r--community/python-redis/precision.patch95
-rw-r--r--community/qcad/PKGBUILD6
-rw-r--r--community/reflector/PKGBUILD8
-rw-r--r--community/rust/PKGBUILD9
-rw-r--r--community/rust/config.toml.patch9
-rw-r--r--community/smbnetfs/PKGBUILD4
-rw-r--r--community/teamspeak3-server/PKGBUILD4
-rw-r--r--community/tensorflow/PKGBUILD2
28 files changed, 79 insertions, 243 deletions
diff --git a/community/aubio/PKGBUILD b/community/aubio/PKGBUILD
new file mode 100644
index 00000000..b96e10aa
--- /dev/null
+++ b/community/aubio/PKGBUILD
@@ -0,0 +1,8 @@
+eval "$(
+ declare -f prepare | \
+ sed '
+ /^{/ a patch -d "${pkgbase}-${pkgver}" -p1 -i "${srcdir}/assert-almost.patch"
+ '
+)"
+source+=(assert-almost.patch)
+sha512sums+=('3a946aaf305ee93ad70ca3b26529fdd58822c9bd177b5a00ace99426b1ba50672d24331d13b6b172a0f8d01ed23feea478b6a15f379d6affa796eb6c2aaadeb2')
diff --git a/community/aubio/assert-almost.patch b/community/aubio/assert-almost.patch
new file mode 100644
index 00000000..9951636e
--- /dev/null
+++ b/community/aubio/assert-almost.patch
@@ -0,0 +1,27 @@
+--- a/python/tests/test_hztomel.py 2019-03-07 15:05:44.804472410 +0100
++++ b/python/tests/test_hztomel.py 2019-03-07 15:05:44.804472410 +0100
+@@ -17,10 +17,10 @@
+ assert_equal(hztomel(0.), 0.)
+ assert_almost_equal(hztomel(400. / 3.), 2., decimal=5)
+ assert_almost_equal(hztomel(1000. / 3), 5.)
+- assert_equal(hztomel(200.), 3.)
++ assert_almost_equal(hztomel(200.), 3.)
+ assert_almost_equal(hztomel(1000.), 15)
+- assert_almost_equal(hztomel(6400), 42)
+- assert_almost_equal(hztomel(40960), 69)
++ assert_almost_equal(hztomel(6400), 42, decimal=5)
++ assert_almost_equal(hztomel(40960), 69, decimal=5)
+
+ for m in np.linspace(0, 1000, 100):
+ assert_almost_equal(hztomel(meltohz(m)) - m, 0, decimal=3)
+--- a/python/tests/test_hztomel.py 2019-03-07 15:16:06.396709250 +0100
++++ b/python/tests/test_hztomel.py 2019-03-07 15:16:06.396709250 +0100
+@@ -28,7 +28,7 @@
+ def test_meltohz(self):
+ assert_equal(meltohz(0.), 0.)
+ assert_almost_equal(meltohz(2), 400. / 3., decimal=4)
+- assert_equal(meltohz(3.), 200.)
++ assert_almost_equal(meltohz(3.), 200., decimal=5)
+ assert_almost_equal(meltohz(5), 1000. / 3., decimal=4)
+ assert_almost_equal(meltohz(15), 1000., decimal=4)
+ assert_almost_equal(meltohz(42), 6400., decimal=2)
diff --git a/community/broadcom-wl-dkms/PKGBUILD b/community/broadcom-wl-dkms/PKGBUILD
index 49b55e6e..f16f641c 100644
--- a/community/broadcom-wl-dkms/PKGBUILD
+++ b/community/broadcom-wl-dkms/PKGBUILD
@@ -1,2 +1,4 @@
source_i686=("https://docs.broadcom.com/docs-and-downloads/docs/linux_sta/hybrid-v35-nodebug-pcoem-${pkgver//./_}.tar.gz")
sha256sums_i686=('4f8b70b293ac8cc5c70e571ad5d1878d0f29d133a46fe7869868d9c19b5058cd')
+source_pentium4=("${source_i686[@]}")
+sha256sums_pentium4=("${sha256sums_i686[@]}")
diff --git a/community/buildah/PKGBUILD b/community/buildah/PKGBUILD
deleted file mode 100644
index 4fa61167..00000000
--- a/community/buildah/PKGBUILD
+++ /dev/null
@@ -1,8 +0,0 @@
-# see https://github.com/projectatomic/buildah/issues/990
-
-eval "$(
- declare -f prepare | \
- sed '
- /}/ i find $srcdir -type f -exec sed -i "s/4294967295/2147483647/g" {} \\;
- '
-)"
diff --git a/community/dart/PKGBUILD b/community/dart/PKGBUILD
index 452a714f..8655f388 100644
--- a/community/dart/PKGBUILD
+++ b/community/dart/PKGBUILD
@@ -1,2 +1,5 @@
source=("$pkgname-$pkgver-32.zip::http://storage.googleapis.com/dart-archive/channels/stable/release/latest/sdk/dartsdk-linux-ia32-release.zip")
-sha512sums=('7723a38f9ed4b9f7d0d2b2098bfacc2eaeb2fa1d75591efd82f8d2e211625c37e10839251f89cd342008cc912e3921ef473a63e7ee74b6cd1853bd1999759fd1')
+sha512sums=('a4fd1cb1397659bd3d58b533415a7d8d3a8b46926960aa2bf3b968a225239de3d84e83397d5792ecc5311fb46b9375ca1e834752d1e6d0f46a2b22e26541fbf9')
+sha512sums_x86_64=('c3433c0f3ecf6535f07f2d029ab4edd48ec03c9029bccf1688c494a7c6405de050ca2f4877f3a65ec65f9bf4e379282574f034609513034cd84626bfc9d27bdb')
+
+sha512sums_x86_64=('c3433c0f3ecf6535f07f2d029ab4edd48ec03c9029bccf1688c494a7c6405de050ca2f4877f3a65ec65f9bf4e379282574f034609513034cd84626bfc9d27bdb')
diff --git a/community/eclipse/PKGBUILD b/community/eclipse/PKGBUILD
index 5da20b19..b6bc2bfd 100644
--- a/community/eclipse/PKGBUILD
+++ b/community/eclipse/PKGBUILD
@@ -7,3 +7,5 @@ sha256sums_i686=('70ae1934385b0b7c25e5a76bfcd6d092bfd8d19ce451c3d909afa3cf244845
'59eb59fd362e4daa0b17bb87a2fbb1019dfb86be1546f398055f491c6303476b'
'09db32c2d958e357b3a959a6860240f3e1eb40f7ffa1815f31661f7f117dd980'
'c7c40966c6cecb719f43487476a52e84f86f680fc34d3be7ae535e03be212b4f')
+source_pentium4=("${source_i686[@]}")
+sha256sums_pentium4=("${sha256sums_i686[@]}")
diff --git a/community/freebasic/PKGBUILD b/community/freebasic/PKGBUILD
index dcfb58df..b368c56c 100644
--- a/community/freebasic/PKGBUILD
+++ b/community/freebasic/PKGBUILD
@@ -1,9 +1,11 @@
source_i686=("http://downloads.sourceforge.net/fbc/FreeBASIC-${pkgver}-linux-x86.tar.xz")
md5sums_i686=('2d0332cc289ec1ba59b017c3a2d4bceb')
+source_pentium4=("${source_i686[@]}")
+md5sums_pentium4=("${md5sums_i686[@]}")
eval "$(
declare -f prepare | \
sed '
- /CARCH/ a [[ "$CARCH" = "i686" ]] && _arch=x86
+ /CARCH/ a [[ "$CARCH" = "i686" ]] && _arch=x86; [[ "$CARCH" = "pentium4" ]] && _arch=x86
'
)"
diff --git a/community/gap/PKGBUILD b/community/gap/PKGBUILD
index b9a33e53..d5bf1291 100644
--- a/community/gap/PKGBUILD
+++ b/community/gap/PKGBUILD
@@ -1,6 +1,6 @@
eval "$(
declare -f package_gap-packages | \
sed '
- /chrpath/ s/x86_64-pc-linux-gnu-default64/i686-pc-linux-gnu-default32/
+ /chrpath/ s/x86_64-/i686-/
'
)"
diff --git a/community/gcc7/PKGBUILD b/community/gcc7/PKGBUILD
deleted file mode 100644
index 2fc92ce0..00000000
--- a/community/gcc7/PKGBUILD
+++ /dev/null
@@ -1,13 +0,0 @@
-# something is missing - no idea what and why :-D
-
-eval "$(
- declare -f package_gcc7-libs | \
- sed '
- /libgcc_s/ d
- s@libsanitizer/{a,l,ub,t}san@libsanitizer/{a,l,ub}san@
- '
- declare -f package_gcc7 | \
- sed '
- /^\s*rm .*lib{stdc++,gcc_s}\.so;$/ s/;$/*;/
- '
-)"
diff --git a/community/go/PKGBUILD b/community/go/PKGBUILD
index 106707ad..d28d6699 100644
--- a/community/go/PKGBUILD
+++ b/community/go/PKGBUILD
@@ -9,4 +9,9 @@ eval "$(
'
)"
-export GOARCH=386 GO386=387
+eval "$(
+ declare -f build check _package \
+ | sed '
+ s/\(export GOARCH=\)amd64/\1386 GO386=387/
+ '
+)"
diff --git a/community/grumpy/4f3cc3ed446170a161cf8ecb644a740ac233b005.patch b/community/grumpy/4f3cc3ed446170a161cf8ecb644a740ac233b005.patch
deleted file mode 100644
index ffe0f2ed..00000000
--- a/community/grumpy/4f3cc3ed446170a161cf8ecb644a740ac233b005.patch
+++ /dev/null
@@ -1,30 +0,0 @@
-From 4f3cc3ed446170a161cf8ecb644a740ac233b005 Mon Sep 17 00:00:00 2001
-From: Alan Justino <alan.justino@yahoo.com.br>
-Date: Wed, 7 Mar 2018 19:30:45 -0300
-Subject: [PATCH] Fix int underflow on 32bit CPUs
-
----
- tools/pkgc.go | 10 ++++++++++
- 1 file changed, 10 insertions(+)
-
-diff --git a/tools/pkgc.go b/tools/pkgc.go
-index e04017c7..93a6fe7d 100644
---- a/tools/pkgc.go
-+++ b/tools/pkgc.go
-@@ -75,6 +75,16 @@ func getConst(name string, v constant.Value) string {
- } else {
- format = "float64(%s)"
- }
-+ } else {
-+ if i, exact := constant.Int64Val(v); exact {
-+ if i > math.MinInt8 {
-+ format = "int(%s)"
-+ } else if i > math.MinInt32 {
-+ format = "int32(%s)"
-+ } else {
-+ format = "int64(%s)"
-+ }
-+ }
- }
- case constant.Float:
- format = "float64(%s)"
diff --git a/community/grumpy/PKGBUILD b/community/grumpy/PKGBUILD
deleted file mode 100644
index 9f331e83..00000000
--- a/community/grumpy/PKGBUILD
+++ /dev/null
@@ -1,18 +0,0 @@
-source+=(
- '4f3cc3ed446170a161cf8ecb644a740ac233b005.patch'
- 'ef4791393db1ab586400d326ae7d7993e5610d00.patch'
-)
-unset md5sums
-sha512sums=(
- 'SKIP'
- 'e86c54bd4bc3492eae0b1cf69a5ea717130024bc6088e994a9a0fae040fdc6962bbbd50cfa4a66b6db228360dd32c0318003f2248f0e41443b60990c67ebcf50'
- 'f646c59e2b1cab40f67c0e150d33bae55bf8d01142c2e6f7d52c331909c5ecbfcd004b4aaafefb07cea268f9dd1c406c4da77e18453097fc0e3f11467b9a39c8'
-)
-eval "$(
- declare -f prepare | \
- sed '
- 2 a cd "$srcdir/grumpy" \
- patch -p1 -i "$srcdir/ef4791393db1ab586400d326ae7d7993e5610d00.patch" \
- patch -p1 -i "$srcdir/4f3cc3ed446170a161cf8ecb644a740ac233b005.patch"
- '
-)"
diff --git a/community/grumpy/ef4791393db1ab586400d326ae7d7993e5610d00.patch b/community/grumpy/ef4791393db1ab586400d326ae7d7993e5610d00.patch
deleted file mode 100644
index c8894732..00000000
--- a/community/grumpy/ef4791393db1ab586400d326ae7d7993e5610d00.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-From ef4791393db1ab586400d326ae7d7993e5610d00 Mon Sep 17 00:00:00 2001
-From: Alan Justino <alan.justino@yahoo.com.br>
-Date: Wed, 7 Mar 2018 19:00:29 -0300
-Subject: [PATCH] Fix overflow on math.MaxInt64
-
----
- tools/pkgc.go | 6 +++++-
- 1 file changed, 5 insertions(+), 1 deletion(-)
-
-diff --git a/tools/pkgc.go b/tools/pkgc.go
-index 4b08aac5..e04017c7 100644
---- a/tools/pkgc.go
-+++ b/tools/pkgc.go
-@@ -65,7 +65,11 @@ func getConst(name string, v constant.Value) string {
- case constant.Int:
- if constant.Sign(v) >= 0 {
- if i, exact := constant.Uint64Val(v); exact {
-- if i > math.MaxInt64 {
-+ if i < math.MaxInt8 {
-+ format = "uint(%s)"
-+ } else if i < math.MaxInt32 {
-+ format = "uint32(%s)"
-+ } else {
- format = "uint64(%s)"
- }
- } else {
diff --git a/community/mit-scheme/PKGBUILD b/community/mit-scheme/PKGBUILD
index 4802c70b..b09ef334 100644
--- a/community/mit-scheme/PKGBUILD
+++ b/community/mit-scheme/PKGBUILD
@@ -1,4 +1,6 @@
source_i686=("https://ftp.gnu.org/gnu/mit-scheme/stable.pkg/$pkgver/$pkgname-$pkgver-i386.tar.gz"
"https://ftp.gnu.org/gnu/mit-scheme/stable.pkg/$pkgver/$pkgname-$pkgver-i386.tar.gz.sig")
-md5sums_i686=('cb3492033e263589da08302a9c6a2572'
+md5sums_i686=('89eb7884c05691ceefad9e7e47aabf5f'
'SKIP')
+source_pentium4=("${source_i686[@]}")
+md5sums_pentium4=("${md5sums_i686[@]}")
diff --git a/community/nvidia-cg-toolkit/PKGBUILD b/community/nvidia-cg-toolkit/PKGBUILD
index b88fdd78..edbe23f6 100644
--- a/community/nvidia-cg-toolkit/PKGBUILD
+++ b/community/nvidia-cg-toolkit/PKGBUILD
@@ -11,3 +11,5 @@ source_i686=(
md5sums_i686=(
'9a9fc5108154808f3b10eafa54df1c74'
)
+source_pentium4=("${source_i686[@]}")
+md5sums_pentium4=("${md5sums_i686[@]}")
diff --git a/community/proselint/PKGBUILD b/community/proselint/PKGBUILD
new file mode 100644
index 00000000..8eb1c478
--- /dev/null
+++ b/community/proselint/PKGBUILD
@@ -0,0 +1,2 @@
+# somehow we take the wrong version?
+sha512sums[0]='76200d75a4adfaf4adcb07e2109707ca3cec322170a070d50b80267125d854cb46fb097f9fe7ce3a584aed8afc35b47749842a36b0d3e19286e1709bbf3d94b5'
diff --git a/community/python-apache-libcloud/PKGBUILD b/community/python-apache-libcloud/PKGBUILD
deleted file mode 100644
index 3f41c8c0..00000000
--- a/community/python-apache-libcloud/PKGBUILD
+++ /dev/null
@@ -1,7 +0,0 @@
-eval "$(
- declare -f check | \
- sed '
- s/python setup.py test/python setup.py test || true/
- s/python2 setup.py test/python2 setup.py test || true/
- '
-)"
diff --git a/community/python-iwlib/PKGBUILD b/community/python-iwlib/PKGBUILD
index 33e85693..d504c3e6 100644
--- a/community/python-iwlib/PKGBUILD
+++ b/community/python-iwlib/PKGBUILD
@@ -3,6 +3,6 @@
eval "$(
declare -f check | \
sed '
- /export PYTHONPATH=/s/x86_64/i686/
+ /export PYTHONPATH=/s/x86_64/${CARCH}/
'
)"
diff --git a/community/python-pip-bootstrap/PKGBUILD b/community/python-pip-bootstrap/PKGBUILD
index 884d3257..a66aad84 100644
--- a/community/python-pip-bootstrap/PKGBUILD
+++ b/community/python-pip-bootstrap/PKGBUILD
@@ -1,13 +1,13 @@
# Maintainer: Andreas Baumann <mail@andreasbaumann.cc>
pkgname=('python-pip-bootstrap' 'python2-pip-bootstrap')
-pkgver='19.0.3'
+pkgver='19.1'
pkgrel='1'
pkgdesc="bootstap pip and setuptools for bootstrapping python"
arch=('x86_64' 'armv6h' 'armv7h')
url="https://bootstrap.pypa.io/"
source=("get-pip-${pkgver}.py::https://bootstrap.pypa.io/get-pip.py")
-sha512sums=('fdbcef1037dca7cc914e2304af657ebd08239cd18c3e79786dc25c8ea39957674e012d7ea8ae2c99006e4b61d3a5e24669ac5771dc186697fd9fdb40b6cc07ae')
+sha512sums=('99520d223819708b8f6e4b839d1fa215e4e8adc7fcd0db6c25a0399cf2fa10034b35673cf450609303646d12497f301ef53b7e7cc65c78e7bce4af0c673555ad')
package_python-pip-bootstrap() {
provides=("python-pip=${pkgver}")
diff --git a/community/python-redis/PKGBUILD b/community/python-redis/PKGBUILD
deleted file mode 100644
index 1720d25f..00000000
--- a/community/python-redis/PKGBUILD
+++ /dev/null
@@ -1,12 +0,0 @@
-# see https://github.com/andymccurdy/redis-py/issues/899
-
-source+=('precision.patch')
-sha512sums+=('ccefada444c145f78098a37880bf7b1c7a2f2e24e92efc62f084610064c4391e4e0792a3e380ca940b73b15d703d5d0f166a8f7d8d17b9d84772b3e870fb74d5')
-
-eval "$(
- declare -f prepare | \
- sed '
- /^{/ a \
- patch -p0 -i precision.patch
- '
-)"
diff --git a/community/python-redis/precision.patch b/community/python-redis/precision.patch
deleted file mode 100644
index aa44b7cf..00000000
--- a/community/python-redis/precision.patch
+++ /dev/null
@@ -1,95 +0,0 @@
---- redis-2.10.6/tests/test_commands.py 2017-09-15 15:05:58.441320136 +0200
-+++ redis-2.10.6/tests/test_commands.py 2017-09-15 15:05:57.429413306 +0200
-@@ -1457,9 +1457,11 @@
-
- r.geoadd('barcelona', *values)
- # redis uses 52 bits precision, hereby small errors may be introduced.
-- assert r.geopos('barcelona', 'place1', 'place2') ==\
-- [(2.19093829393386841, 41.43379028184083523),
-- (2.18737632036209106, 41.40634178640635099)]
-+ res = r.geopos('barcelona', 'place1', 'place2')
-+ assert abs(res[0][0] - 2.19093829393386841) < 0.0001
-+ assert abs(res[0][1] - 41.43379028184083523) < 0.0001
-+ assert abs(res[1][0] - 2.18737632036209106) < 0.0001
-+ assert abs(res[1][1] - 41.40634178640635099) < 0.0001
-
- @skip_if_server_version_lt('4.0.0')
- def test_geopos_no_value(self, r):
-@@ -1504,20 +1506,27 @@
-
- # test a bunch of combinations to test the parse response
- # function.
-- assert r.georadius('barcelona', 2.191, 41.433, 1, unit='km',
-- withdist=True, withcoord=True, withhash=True) ==\
-- [['place1', 0.0881, 3471609698139488,
-- (2.19093829393386841, 41.43379028184083523)]]
--
-- assert r.georadius('barcelona', 2.191, 41.433, 1, unit='km',
-- withdist=True, withcoord=True) ==\
-- [['place1', 0.0881,
-- (2.19093829393386841, 41.43379028184083523)]]
--
-- assert r.georadius('barcelona', 2.191, 41.433, 1, unit='km',
-- withhash=True, withcoord=True) ==\
-- [['place1', 3471609698139488,
-- (2.19093829393386841, 41.43379028184083523)]]
-+ res = r.georadius('barcelona', 2.191, 41.433, 1, unit='km',
-+ withdist=True, withcoord=True, withhash=True)[0]
-+ assert res[0] == 'place1'
-+ assert abs(res[1] - 0.0881) < 0.00001
-+ assert res[2] == 3471609698139488
-+ assert abs(res[3][0] - 2.19093829393386841) < 0.000000001
-+ assert abs(res[3][1] - 41.43379028184083523) < 0.000000001
-+
-+ res = r.georadius('barcelona', 2.191, 41.433, 1, unit='km',
-+ withdist=True, withcoord=True)[0]
-+ assert res[0] == 'place1'
-+ assert abs(res[1] - 0.0881) < 0.0001
-+ assert abs(res[2][0] - 2.19093829393386841) < 0.0000001
-+ assert abs(res[2][1] - 41.43379028184083523) < 0.0000001
-+
-+ res = r.georadius('barcelona', 2.191, 41.433, 1, unit='km',
-+ withhash=True, withcoord=True)[0]
-+ assert res[0] == 'place1'
-+ assert res[1] == 3471609698139488
-+ assert abs(res[2][0] - 2.19093829393386841) < 0.0000001
-+ assert abs(res[2][1] - 41.43379028184083523) < 0.0000001
-
- # test no values.
- assert r.georadius('barcelona', 2, 1, 1, unit='km',
-@@ -1561,7 +1570,7 @@
- r.georadius('barcelona', 2.191, 41.433, 1000,
- store_dist='places_barcelona')
- # instead of save the geo score, the distance is saved.
-- assert r.zscore('places_barcelona', 'place1') == 88.05060698409301
-+ assert abs(r.zscore('places_barcelona', 'place1') - 88.05060698409301) < 0.00000001
-
- @skip_if_server_version_lt('3.2.0')
- def test_georadiusmember(self, r):
-@@ -1573,13 +1582,20 @@
- ['place2', 'place1']
- assert r.georadiusbymember('barcelona', 'place1', 10) == ['place1']
-
-- assert r.georadiusbymember('barcelona', 'place1', 4000,
-+ res = r.georadiusbymember('barcelona', 'place1', 4000,
- withdist=True, withcoord=True,
-- withhash=True) ==\
-- [['place2', 3067.4157, 3471609625421029,
-- (2.187376320362091, 41.40634178640635)],
-- ['place1', 0.0, 3471609698139488,
-- (2.1909382939338684, 41.433790281840835)]]
-+ withhash=True)
-+ r1 = [r for r in res if r[0] == 'place1'][0]
-+ r2 = [r for r in res if r[0] == 'place2'][0]
-+
-+ assert abs(r1[1]) < 0.0001
-+ assert r1[2] == 3471609698139488
-+ assert abs(r1[3][0] - 2.1909382939338684) < 0.0000001
-+ assert abs(r1[3][1] - 41.433790281840835) < 0.0000001
-+ assert abs(r2[1] - 3067.4157) < 0.0001
-+ assert r2[2] == 3471609625421029
-+ assert abs(r2[3][0] - 2.187376320362091) < 0.0000001
-+ assert abs(r2[3][1] - 41.40634178640635) < 0.0000001
-
-
- class TestStrictCommands(object):
diff --git a/community/qcad/PKGBUILD b/community/qcad/PKGBUILD
new file mode 100644
index 00000000..8c6c4ec4
--- /dev/null
+++ b/community/qcad/PKGBUILD
@@ -0,0 +1,6 @@
+# If they ever change their release artifacts again, whoever reads this
+# has my permission to put 'SKIP' into these checksum arrays.
+# deep42thought - 2019-03-28
+sha512sums=(
+ "${sha512sums[@]/d423e6b5159b556f0ee19423d9cf621f1cdf172c1ec6ba46ae88631a848bc9800f8ab34d3d0a75a682a51ff3ec1ccbab0a7bc1e9c589644419c46b35bf128504/49dd8bab8adf01b639d219b560fd0684c51c8348b8db6598721cb924b8e06e1f070d302b8893fc8952ee98c4dd903f69bf1a3d269b304f7d96b91e826e6d9234}"
+)
diff --git a/community/reflector/PKGBUILD b/community/reflector/PKGBUILD
index a56f5997..3cc31f1b 100644
--- a/community/reflector/PKGBUILD
+++ b/community/reflector/PKGBUILD
@@ -1,13 +1,11 @@
-if [ "${pkgver}" = '2018' ]; then
- pkgver='2019.02.09'
-fi
source=(
"https://sources.archlinux32.org/sources/reflector32-${pkgver}.tar.gz"{,.sig}
)
-md5sums=('0f0806c293ee06b2a98e66369ce14e65'
+md5sums=('f0f712807a05291969606ce2a39b0d36'
'SKIP')
-sha512sums=('43dd0465346d88df2356b743e965b0369be98a601a6f0d3b0c0667e8dfe0f4d1e4ad176f85a664d1f5db6dff9cf60127c51f715d0e3877ea35a76ce94b177ed4'
+sha512sums=('c5446752da1a868d96c27c42b174cd47c80ac3e00b6c0a9b70e1339c013b496f4cf3aef535198955050bdef065da36a68b8ea2bb4f6bcb8cf0a37ad81231a25e'
'SKIP')
+
validpgpkeys=('DE9F7688CACF04FEB81A6C590AEEC90755DA7B5A')
eval "$(
declare -f package | \
diff --git a/community/rust/PKGBUILD b/community/rust/PKGBUILD
deleted file mode 100644
index 221bfd43..00000000
--- a/community/rust/PKGBUILD
+++ /dev/null
@@ -1,9 +0,0 @@
-source+=(config.toml.patch)
-sha256sums+=('55d59786b6a24590951688c01910ac331996fc5ea5e20f10d227db24b93b1e74')
-
-eval "$(
- declare -f prepare | \
- sed '
- $ i patch -p1 -i "$srcdir/config.toml.patch"
- '
-)"
diff --git a/community/rust/config.toml.patch b/community/rust/config.toml.patch
deleted file mode 100644
index f479499b..00000000
--- a/community/rust/config.toml.patch
+++ /dev/null
@@ -1,9 +0,0 @@
---- a/config.toml 2019-01-20 19:03:26.718067950 +0100
-+++ b/config.toml 2019-01-20 19:03:52.614834201 +0100
-@@ -25,3 +25,6 @@
-
- [target.x86_64-unknown-linux-gnu]
- llvm-config = "/usr/bin/llvm-config"
-+
-+[target.i686-unknown-linux-gnu]
-+llvm-config = "/usr/bin/llvm-config"
diff --git a/community/smbnetfs/PKGBUILD b/community/smbnetfs/PKGBUILD
new file mode 100644
index 00000000..6c6147a8
--- /dev/null
+++ b/community/smbnetfs/PKGBUILD
@@ -0,0 +1,4 @@
+# https://sourceforge.net/p/smbnetfs/git/ci/f0e109dcc9e14b914d8f5877b4482e79d24a0ad6/
+prepare() {
+ sed -i '\,^#include <attr/xattr.h>$,d' "$srcdir"/$pkgname-$pkgver/src/function.c
+}
diff --git a/community/teamspeak3-server/PKGBUILD b/community/teamspeak3-server/PKGBUILD
index a9a9b912..08d7c2f0 100644
--- a/community/teamspeak3-server/PKGBUILD
+++ b/community/teamspeak3-server/PKGBUILD
@@ -1,2 +1,2 @@
-sha256sums_i686=('501ac40e17413cf864b269edfbf9fb44dfbb8624cfead4e458eff24451ade005')
-
+sha256sums_i686=('d20d1df1d27445c117b47926e70ebd4c62e0338f18aab2c5d2c218ae6c2b0369')
+sha256sums_pentium4=("${sha256sums_i686[@]}")
diff --git a/community/tensorflow/PKGBUILD b/community/tensorflow/PKGBUILD
index bfd09f66..61820fe9 100644
--- a/community/tensorflow/PKGBUILD
+++ b/community/tensorflow/PKGBUILD
@@ -1,7 +1,7 @@
eval "$(
declare -f prepare | \
sed '
- s|export CC_OPT_FLAGS="-march=x86-64"|export CC_OPT_FLAGS="-march=i686"|
+ s|export CC_OPT_FLAGS="-march=x86-64"|export CC_OPT_FLAGS="-march=${CARCH}"|
'
)"