Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/build-support
diff options
context:
space:
mode:
Diffstat (limited to 'build-support')
-rw-r--r--build-support/muon-meson/PKGBUILD6
-rw-r--r--build-support/muon-meson/disabled/PKGBUILD-minimal-static66
2 files changed, 68 insertions, 4 deletions
diff --git a/build-support/muon-meson/PKGBUILD b/build-support/muon-meson/PKGBUILD
index 7ff40b4c..6eb8ba82 100644
--- a/build-support/muon-meson/PKGBUILD
+++ b/build-support/muon-meson/PKGBUILD
@@ -29,8 +29,7 @@ build() {
msg2 "Building stage 2 (muon from bootstrap)"
build-stage1/muon setup \
-D docs=disabled \
- -D static=true \
- -D libpkgconf=disabled \
+ -D libpkgconf=enabled \
-D libcurl=disabled \
-D libarchive=disabled \
build-stage2
@@ -42,8 +41,7 @@ build() {
-D b_lto=false \
-D b_pie=false \
-D docs=disabled \
- -D static=true \
- -D libpkgconf=disabled \
+ -D libpkgconf=enabled \
-D libcurl=disabled \
-D libarchive=disabled \
build
diff --git a/build-support/muon-meson/disabled/PKGBUILD-minimal-static b/build-support/muon-meson/disabled/PKGBUILD-minimal-static
new file mode 100644
index 00000000..384250d7
--- /dev/null
+++ b/build-support/muon-meson/disabled/PKGBUILD-minimal-static
@@ -0,0 +1,66 @@
+# Maintainer: Eric Engestrom <aur [at] engestrom [dot] ch>
+
+pkgname=muon-meson
+pkgver=0.3.1
+pkgrel=3
+pkgdesc="meson implementation in C"
+arch=(x86_64 pentium4 i686 i486)
+url="https://muon.build"
+license=(GPL3)
+source=(
+ "$url/releases/v$pkgver/muon-v$pkgver.tar.gz"
+ "arch-muon")
+sha256sums=('45f6ad728946a0788188004e3a88a77a7d07b48525ce0646430589d1db4c832e'
+ '4e507d5b129cd7de05aca972504ab06c2353b145e7378d15aa75b7d4b1b252e8')
+#depends=(pkgconf curl libarchive)
+depends=(pkgconf)
+#makedepends=(ninja python-yaml scdoc)
+makedepends=(ninja)
+checkdepends=(git)
+provides=(muon)
+
+build() {
+ cd "muon-v$pkgver"
+ rm -rf build*
+
+ msg2 "Building stage 1 (bootstrap)"
+ ./bootstrap.sh build-stage1
+
+ msg2 "Building stage 2 (muon from bootstrap)"
+ build-stage1/muon setup \
+ -D docs=disabled \
+ -D libpkgconf=disabled \
+ -D libcurl=disabled \
+ -D libarchive=disabled \
+ build-stage2
+ ninja -C build-stage2
+
+ msg2 "Building stage 3 (muon from muon)"
+ build-stage2/muon setup \
+ -D prefix=/usr \
+ -D b_lto=false \
+ -D b_pie=false \
+ -D docs=disabled \
+ -D libpkgconf=enabled \
+ -D libcurl=disabled \
+ -D libarchive=disabled \
+ build
+ ninja -C build
+}
+
+check() {
+ cd "muon-v$pkgver/build"
+ ./muon test || true
+}
+
+package() {
+ cd "muon-v$pkgver/build"
+ DESTDIR="$pkgdir" ./muon install
+
+ install -Dm775 "$srcdir/arch-muon" "$pkgdir/usr/bin/arch-muon"
+
+ # remove this as the `meson` package also provides it
+ # muon only has a `docs` option right now, so
+ # downloading/generating/deleting is the only option :/
+# rm "$pkgdir"/usr/share/man/man3/meson-reference.3
+}