Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/build-support/ruby-bootstrap/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'build-support/ruby-bootstrap/PKGBUILD')
-rw-r--r--build-support/ruby-bootstrap/PKGBUILD54
1 files changed, 54 insertions, 0 deletions
diff --git a/build-support/ruby-bootstrap/PKGBUILD b/build-support/ruby-bootstrap/PKGBUILD
new file mode 100644
index 00000000..d700fa62
--- /dev/null
+++ b/build-support/ruby-bootstrap/PKGBUILD
@@ -0,0 +1,54 @@
+# Maintainer: Anatol Pomozov <anatol.pomozov@gmail.com>
+# Maintainer: Andreas 'Segaja' Schleifer <segaja at archlinux dot org>
+# Maintainer: Tim Meusel <tim@bastelfreak.de>
+# Contributor: Thomas Dziedzic <gostrc@gmail.com>
+# Contributor: Allan McRae <allan@archlinux.org>
+# Contributor: John Proctor <jproctor@prium.net>
+# Contributor: Jeramy Rutley <jrutley@gmail.com>
+# Arch32 bootstrap
+# Contributor: Andreas Baumann <andreas.baumann@eurospider.com>
+
+pkgname=(ruby-bootstrap)
+pkgver=3.0.4
+pkgrel=9
+arch=(i486 i686 pentium4 x86_64)
+url='https://www.ruby-lang.org/en/'
+license=(BSD custom)
+makedepends=(gdbm openssl libffi doxygen graphviz libyaml ttf-dejavu tk)
+options=(debug !emptydirs !lto) # Disable LTO until fixes for https://bugs.ruby-lang.org/issues/18062 released
+source=(https://cache.ruby-lang.org/pub/ruby/${pkgver:0:3}/ruby-${pkgver}.tar.xz)
+sha512sums=('53bf7dd403b0c68af9691882ad8ed7422c8d1f496627428fb4c3caf0b0313715524b744c5f453aced2d49e16e55f3f45b46b9a77aa3097dbfcae7caa0208194b')
+
+build() {
+ cd ruby-${pkgver}
+
+ ./configure \
+ --prefix=/opt/${pkgname}-${pkgver} \
+ --enable-shared \
+ --enable-rpath \
+ --with-dbm-type=gdbm_compat
+
+ make
+}
+
+check() {
+ cd ruby-${pkgver}
+
+# make test
+}
+
+package_ruby-bootstrap() {
+ pkgdesc='An object-oriented language for quick and easy programming'
+ depends=(gdbm openssl libffi libyaml libxcrypt gmp zlib)
+ optdepends=(
+ 'ruby-docs: Ruby documentation'
+ 'tk: for Ruby/TK'
+ )
+
+ cd ruby-${pkgver}
+
+ make DESTDIR="${pkgdir}" install-nodoc
+
+ install -D -m644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}-${pkgver}/LICENSE"
+ install -D -m644 BSDL "${pkgdir}/usr/share/licenses/${pkgname}-${pkgver}/BSDL"
+}