Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--core/openssl-1.1/PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/core/openssl-1.1/PKGBUILD b/core/openssl-1.1/PKGBUILD
new file mode 100644
index 00000000..8ab857a0
--- /dev/null
+++ b/core/openssl-1.1/PKGBUILD
@@ -0,0 +1,28 @@
+# switch to 32-bit target (was linux-elf before, which I think is wrong also for i686)
+eval "$(
+ declare -f build | \
+ sed '
+ s@linux-x86_64@linux-generic32@
+ s@ enable-ec_nistp_64_gcc_128 @ @
+ '
+)"
+
+# i486-specific, disable hand-crafted assembly code
+if [ "${CARCH}" = "i486" ]; then
+ eval "$(
+ declare -f build | \
+ sed '
+ s@no-ssl3-method@no-ssl3-method 386@
+ '
+ )"
+fi
+
+# i686-specific, disable hand-crafted assembly code
+if [ "${CARCH}" = "i686" ]; then
+ eval "$(
+ declare -f build | \
+ sed '
+ s@no-ssl3-method@no-ssl3-method no-sse2@
+ '
+ )"
+fi