Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--extra/js102/PKGBUILD14
1 files changed, 12 insertions, 2 deletions
diff --git a/extra/js102/PKGBUILD b/extra/js102/PKGBUILD
index df23dbac..00dd2d2d 100644
--- a/extra/js102/PKGBUILD
+++ b/extra/js102/PKGBUILD
@@ -18,6 +18,10 @@ if [ "$CARCH" = 'i486' -o "$CARCH" = 'i686' ]; then
'
)"
fi
+# no rust on i486
+if [ "$CARCH" = 'i486' ]; then
+ makedepends=(${makedepends[@]//rust/})
+fi
# hard pinning rust version (as it fails with rust 1.50)
# this rust version now needs llvm11
@@ -27,5 +31,11 @@ fi
# rust is linked against old versions of LLVM and Openssl
# and cannot be rebuilt currently
-makedepends+=(llvm14)
-makedepends+=(openssl-1.1)
+if [ "$CARCH" = 'pentium4' -o "$CARCH" = 'i686' ]; then
+ makedepends+=(llvm14-libs)
+ makedepends+=(openssl-1.1)
+fi
+
+if [ "$CARCH" = 'i486' ]; then
+ makedepends+=(openssl-1.1)
+fi