Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--extra/re2/PKGBUILD17
-rw-r--r--extra/re2/re2-2020-05-01-compile-test-out-of-memory-fix.patch12
2 files changed, 0 insertions, 29 deletions
diff --git a/extra/re2/PKGBUILD b/extra/re2/PKGBUILD
deleted file mode 100644
index 1cd34742..00000000
--- a/extra/re2/PKGBUILD
+++ /dev/null
@@ -1,17 +0,0 @@
-# compiler-test fails in InsufficientMemory test due to the change of
-# the size of the DFA
-# bug: https://github.com/google/re2/issues/256
-# patch: https://github.com/google/re2/commit/bde1ea09550a61b4a092cdf0e3ba8dca4200947a
-source+=('re2-2020-05-01-compile-test-out-of-memory-fix.patch')
-sha256sums+=('bef199b3c77cd6477d9f3950acc5d017ce4a53e447827f01a4706e7e8980b220')
-
-eval "$(
- {
- declare -f prepare || \
- printf 'prepare() {\n}\n'
- } \
- | sed '
- $ i cd "$pkgname-$_re2ver"; patch -Np1 -i "${srcdir}"/re2-2020-05-01-compile-test-out-of-memory-fix.patch
- '
-)"
-
diff --git a/extra/re2/re2-2020-05-01-compile-test-out-of-memory-fix.patch b/extra/re2/re2-2020-05-01-compile-test-out-of-memory-fix.patch
deleted file mode 100644
index 8b8b874c..00000000
--- a/extra/re2/re2-2020-05-01-compile-test-out-of-memory-fix.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -rauN re2-2020-05-01/re2/testing/compile_test.cc re2-2020-05-01-compile-test-out-of-memory-fix-patch/re2/testing/compile_test.cc
---- re2-2020-05-01/re2/testing/compile_test.cc 2020-04-23 17:56:11.000000000 +0200
-+++ re2-2020-05-01-compile-test-out-of-memory-fix-patch/re2/testing/compile_test.cc 2020-05-16 17:17:05.570251742 +0200
-@@ -236,7 +236,7 @@
- "^(?P<name1>[^\\s]+)\\s+(?P<name2>[^\\s]+)\\s+(?P<name3>.+)$",
- Regexp::LikePerl, NULL);
- EXPECT_TRUE(re != NULL);
-- Prog* prog = re->CompileToProg(920);
-+ Prog* prog = re->CompileToProg(850);
- // If the memory budget has been exhausted, compilation should fail
- // and return NULL instead of trying to do anything with NoMatch().
- EXPECT_TRUE(prog == NULL);