Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--build-support/muon-meson/PKGBUILD2
-rw-r--r--build-support/muon-meson/disabled/PKGBUILD-minimal-static (renamed from build-support/disabled/muon-meson/PKGBUILD-minimal-static)0
-rw-r--r--core/gettext/PKGBUILD3
-rw-r--r--core/pacman/PKGBUILD10
4 files changed, 12 insertions, 3 deletions
diff --git a/build-support/muon-meson/PKGBUILD b/build-support/muon-meson/PKGBUILD
index 384250d7..6eb8ba82 100644
--- a/build-support/muon-meson/PKGBUILD
+++ b/build-support/muon-meson/PKGBUILD
@@ -29,7 +29,7 @@ build() {
msg2 "Building stage 2 (muon from bootstrap)"
build-stage1/muon setup \
-D docs=disabled \
- -D libpkgconf=disabled \
+ -D libpkgconf=enabled \
-D libcurl=disabled \
-D libarchive=disabled \
build-stage2
diff --git a/build-support/disabled/muon-meson/PKGBUILD-minimal-static b/build-support/muon-meson/disabled/PKGBUILD-minimal-static
index 384250d7..384250d7 100644
--- a/build-support/disabled/muon-meson/PKGBUILD-minimal-static
+++ b/build-support/muon-meson/disabled/PKGBUILD-minimal-static
diff --git a/core/gettext/PKGBUILD b/core/gettext/PKGBUILD
index 5a2c876d..be7f41e3 100644
--- a/core/gettext/PKGBUILD
+++ b/core/gettext/PKGBUILD
@@ -10,3 +10,6 @@ eval "$(
if [ "${CARCH}" = "i486" ]; then
makedepends+=(icu73)
fi
+
+# currrenly broken around libsitter
+makedepends=(${makedepends[@]//emacs/})
diff --git a/core/pacman/PKGBUILD b/core/pacman/PKGBUILD
index 99b6a18e..61a6bf13 100644
--- a/core/pacman/PKGBUILD
+++ b/core/pacman/PKGBUILD
@@ -45,15 +45,17 @@ if [ "${CARCH}" = "i486" ]; then
fi
# If this still applies, it only does for i486:
-if [ "${CARCH}" = "i486" ]; then
+# (while not having Python, it's not working on any CARCH)
+#if [ "${CARCH}" = "i486" ]; then
# broken Python/asciidoc
eval "$(
declare -f build | \
sed '
/meson/s/-Ddoc=enabled/-Ddoc=disabled/
+ /meson/s/-DDdoxygen=enabled/-DDdoxygen=disabled/
'
)"
-fi
+#fi
# gettext is linked against old ICU verison on i486, use ICU 72 stub
if [ "${CARCH}" = "i486" ]; then
@@ -61,3 +63,7 @@ if [ "${CARCH}" = "i486" ]; then
fi
sha256sums[0]='SKIP'
+
+# fails happilly at the moment, going full risk now and installing it anyway..
+unset check
+unset checkdepends