Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--core/curl/PKGBUILD5
-rw-r--r--core/libarchive/PKGBUILD1
-rw-r--r--core/xz/PKGBUILD12
3 files changed, 18 insertions, 0 deletions
diff --git a/core/curl/PKGBUILD b/core/curl/PKGBUILD
index 6d7d6522..70a13a74 100644
--- a/core/curl/PKGBUILD
+++ b/core/curl/PKGBUILD
@@ -1,3 +1,8 @@
# Valgrind seems broken for now
unset check
unset checkdepends
+
+# temporary, we still build a version with rtmpdump though upstream now
+# has no dependency on anymore?
+depends+=(rtmpdump)
+
diff --git a/core/libarchive/PKGBUILD b/core/libarchive/PKGBUILD
index c0dc8804..86ca2216 100644
--- a/core/libarchive/PKGBUILD
+++ b/core/libarchive/PKGBUILD
@@ -14,3 +14,4 @@ eval "$(
# temporary, we still build a version with libb2 though upstream now
# has no dependency on libb2 anymore?
depends+=(libb2)
+
diff --git a/core/xz/PKGBUILD b/core/xz/PKGBUILD
new file mode 100644
index 00000000..dce2ecd7
--- /dev/null
+++ b/core/xz/PKGBUILD
@@ -0,0 +1,12 @@
+makedepends=(${makedepends[@]//doxygen/})
+eval "$(
+ declare -f build | \
+ sed '
+ /configure/s/--enable-doxygen/--disable-doxygen/
+ '
+)"
+
+if [ "${CARCH}" = "i486" ]; then
+ sha256sums[0]='SKIP'
+ sha512sums[0]='SKIP'
+fi