Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/extra
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2021-02-14 09:31:42 +0100
committerAndreas Baumann <mail@andreasbaumann.cc>2021-02-14 09:31:42 +0100
commit2e4cda8ece8fe9ff93bd41e0957a0bec31af34ff (patch)
tree6989d7c8f3b8f99c4846df949603715bf359f924 /extra
parent0df69c0c232f568e25422054b9eb094495d9f7dd (diff)
extra/zita-resampler: SSE2 fix for i686 and i486
Diffstat (limited to 'extra')
-rw-r--r--extra/zita-resampler/PKGBUILD10
1 files changed, 10 insertions, 0 deletions
diff --git a/extra/zita-resampler/PKGBUILD b/extra/zita-resampler/PKGBUILD
new file mode 100644
index 00000000..9cc348a7
--- /dev/null
+++ b/extra/zita-resampler/PKGBUILD
@@ -0,0 +1,10 @@
+# SSE2 only for pentium4, not for i686/i486
+if [ "${CARCH}" = "i686" ] || [ "${CARCH}" = "i486" ]; then
+ eval "$(
+ declare -f prepare | \
+ sed '
+ /native/ a \
+ sed -i '\''/-DENABLE_SSE2/d'\'' source/Makefile
+ '
+ )"
+fi