Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/extra/thunderbird
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2019-09-20 13:05:01 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2019-09-20 13:05:01 +0200
commit3a2c53b1c46a9fd0a955ebb04026a1912d8d2002 (patch)
tree79848fbe36e87728c8eb40585b1b8730c7f0986a /extra/thunderbird
parentde84d1feaef5355846fa70d7afd8f21af07ff900 (diff)
extra/thunderbird: trying to handle out-of-memory and resource consumption issues
Diffstat (limited to 'extra/thunderbird')
-rw-r--r--extra/thunderbird/PKGBUILD17
1 files changed, 17 insertions, 0 deletions
diff --git a/extra/thunderbird/PKGBUILD b/extra/thunderbird/PKGBUILD
index 33e3f300..b7adf6b6 100644
--- a/extra/thunderbird/PKGBUILD
+++ b/extra/thunderbird/PKGBUILD
@@ -9,3 +9,20 @@ eval "$(
s/ac_add_options --enable-linker=gold/ac_add_options --enable-linker=bfd/
'
)"
+
+# from VoidLinux, avoid excessive debug symbols in rust leading
+# to out-of-memory situations
+eval "$(
+ declare -f build | \
+ sed '
+ 2 a sed -i \"s/debug_info = '2'/debug_info = '1'/\" build/moz.configure/toolchain.configure
+ '
+)"
+
+# don't kill build slaves by auto-guessing available CPU cores
+eval "$(
+ declare -f build | \
+ sed '
+ 2 a export MOZ_MAKE_FLAGS=-j1
+ '
+)"