Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/extra/linux-zen
diff options
context:
space:
mode:
authorErich Eckner <git@eckner.net>2018-09-30 20:38:29 +0200
committerErich Eckner <git@eckner.net>2018-09-30 20:38:29 +0200
commit0653374c47a5c1679d86cfbe251d258151fa018f (patch)
treed8260481140f843807605b29dc1f369539b2a27d /extra/linux-zen
parent5752df693f7d20139680ec947136c687de4532dd (diff)
extra/linux-zen: new version + use tarballer
Diffstat (limited to 'extra/linux-zen')
-rw-r--r--extra/linux-zen/PKGBUILD61
-rw-r--r--extra/linux-zen/config2
2 files changed, 61 insertions, 2 deletions
diff --git a/extra/linux-zen/PKGBUILD b/extra/linux-zen/PKGBUILD
index 5adcd9d6..96976146 100644
--- a/extra/linux-zen/PKGBUILD
+++ b/extra/linux-zen/PKGBUILD
@@ -3,7 +3,7 @@
# fail if upstream's .config changes
for ((i=0; i<${#sha256sums[@]}; i++)); do
if [ "${sha256sums[${i}]}" = '8a852e70606513c77fc513d6ef970273345cc895d90e3f283ae103853bf50c41' ]; then
- sha256sums[${i}]='7c355407a2827005bc200e302ab578287fb40d540d95a10b9191151e1c816302'
+ sha256sums[${i}]='0fa2c1eef3f46e1e0f22aa6a4da555cca6234bcd12c8aae84503ce5f6c178348'
fi
done
@@ -17,3 +17,62 @@ eval "$(
}
'
)"
+
+# use our tarballer instead of cloning from git
+for ((i=0; i<${#source[@]}; i++)); do
+ infos=$(
+ printf '%s\n' "${source[${i}]}" | \
+ sed -n '
+ s@^\(\([^:]\+\)::\)\?\(git\|hg\)+\([^#?]\+\)\(?signed\)\?#\(\(tag\|commit\)=\S\+\)$@\3 \2 \4 \5 \6@
+ T
+ p
+ '
+ )
+ if [ -n "${infos}" ]; then
+ source[${i}]=$(
+ type="${infos%% *}"
+ infos="${infos#* }"
+ if [ -n "${infos%% *}" ]; then
+ prefix="${infos%% *}"
+ else
+ prefix=''
+ fi
+ infos="${infos#* }"
+ repo="${infos%% *}"
+ repo64=$(
+ printf '%s' "${repo}" | \
+ base64 -w0 | \
+ sed 's/=/%3D/g'
+ )
+ infos="${infos#* }"
+ if [ "${infos%% *}" = '?signed' ]; then
+ key_check=$(
+ printf '&valid_keys='
+ printf '%s,' "${validpgpkeys[@]}" | \
+ sed 's/,$//'
+ )
+ else
+ key_check=''
+ fi
+ infos="${infos#* }"
+ if [ -z "${prefix}" ]; then
+ prefix="${repo%.git}"
+ prefix="${prefix##*/}"
+ fi
+ prefix_64=$(
+ printf '%s/' "${prefix}" | \
+ base64 -w0 | \
+ sed 's/=/%3D/g'
+ )
+
+ printf '%s-%s.tar.gz::https://archive-server.archlinux32.org/?t=%s&p=%s&r=%s%s&%s\n' \
+ "${prefix}" \
+ "${pkgver}" \
+ "${type}" \
+ "${prefix_64}" \
+ "${repo64}" \
+ "${key_check}" \
+ "${infos}"
+ )
+ fi
+done
diff --git a/extra/linux-zen/config b/extra/linux-zen/config
index e0dab22e..cc18ead9 100644
--- a/extra/linux-zen/config
+++ b/extra/linux-zen/config
@@ -1,6 +1,6 @@
#
# Automatically generated file; DO NOT EDIT.
-# Linux/x86 4.18.9-zen1 Kernel Configuration
+# Linux/x86 4.18.10-zen1 Kernel Configuration
#
#