Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/extra/gdal/PKGBUILD
diff options
context:
space:
mode:
authorErich Eckner <git@eckner.net>2023-05-22 20:18:50 +0200
committerErich Eckner <git@eckner.net>2023-05-22 20:18:50 +0200
commite74cde76c104df82b120a7b13964cb786da8f565 (patch)
tree39967e24037929c04aaf79922aa260b437a60a5e /extra/gdal/PKGBUILD
parent73e1d3b448cc583ab38cae4d61a26f313fad946b (diff)
community -> extra
Diffstat (limited to 'extra/gdal/PKGBUILD')
-rw-r--r--extra/gdal/PKGBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/extra/gdal/PKGBUILD b/extra/gdal/PKGBUILD
new file mode 100644
index 00000000..8a896f4e
--- /dev/null
+++ b/extra/gdal/PKGBUILD
@@ -0,0 +1,35 @@
+# enable SSE/SSE2 where appripriate
+if [ "${CARCH}" = "i486" -o "${CARCH}" = "i686" ]; then
+ eval "$(
+ declare -f build | \
+ sed '
+ s|./configure |./configure --with-sse=no --with-ssse3=no --with-avx=no |
+ '
+ )"
+fi
+if [ "${CARCH}" = "pentium4" ]; then
+ eval "$(
+ declare -f build | \
+ sed '
+ s|./configure |./configure --with-sse=yes --with-ssse3=no --with-avx=no |
+ '
+ )"
+fi
+
+# i486 has a stack smash when building the Python bindings (see FS32#188)
+if [ "${CARCH}" = "i486" ]; then
+ eval "$(
+ declare -f build | \
+ sed '
+ /swig\/python/d
+ /python setup.py build/d
+ '
+ )"
+ eval "$(
+ declare -f package_python-gdal | \
+ sed '
+ 3 i if false; then
+ $ i fi
+ '
+ )"
+fi