Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/core/systemd/lz4-test-compress-partial.patch
diff options
context:
space:
mode:
authorErich Eckner <git@eckner.net>2019-01-21 10:09:43 +0100
committerErich Eckner <git@eckner.net>2019-01-21 10:09:43 +0100
commit70a7c30b8196a4398cf755b93507516d0f83be56 (patch)
tree209c100961292220e8af6a75f6eccf2cf9a0e440 /core/systemd/lz4-test-compress-partial.patch
parent22d62828d91c69d6ec0db0ab42be321a0370f561 (diff)
parentbdaf29915201bec1e7ebffb37bf9f96a7dd529e8 (diff)
Merge branch 'master' into i486
Diffstat (limited to 'core/systemd/lz4-test-compress-partial.patch')
-rw-r--r--core/systemd/lz4-test-compress-partial.patch31
1 files changed, 0 insertions, 31 deletions
diff --git a/core/systemd/lz4-test-compress-partial.patch b/core/systemd/lz4-test-compress-partial.patch
deleted file mode 100644
index 421e186f..00000000
--- a/core/systemd/lz4-test-compress-partial.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-diff --git a/meson.build b/meson.build
-index 554e67e5dd..3636a0ff8c 100644
---- a/meson.build
-+++ b/meson.build
-@@ -1084,6 +1084,7 @@ conf.set10('HAVE_XZ', have)
- want_lz4 = get_option('lz4')
- if want_lz4 != 'false' and not fuzzer_build
- liblz4 = dependency('liblz4',
-+ version : '>= 1.8.3',
- required : want_lz4 == 'true')
- have = liblz4.found()
- else
-diff --git a/src/journal/test-compress.c b/src/journal/test-compress.c
-index 7addf318d6..fb0db190b2 100644
---- a/src/journal/test-compress.c
-+++ b/src/journal/test-compress.c
-@@ -227,13 +227,10 @@ static void test_lz4_decompress_partial(void) {
- assert_se(r >= 0);
- log_info("Decompressed partial %i/%i → %i", 12, HUGE_SIZE, r);
-
-- /* We expect this to fail, because that's how current lz4 works. If this
-- * call succeeds, then lz4 has been fixed, and we need to change our code.
-- */
- r = LZ4_decompress_safe_partial(buf, huge,
- compressed,
- 12, HUGE_SIZE-1);
-- assert_se(r < 0);
-+ assert_se(r >= 0);
- log_info("Decompressed partial %i/%i → %i", 12, HUGE_SIZE-1, r);
- }
- #endif